Search results

  1. Mikerizer

    Radiator leak, MAYBE a head gasket problem

    The block test revealed NO signs of exhaust gasses in the radiator. What a relief! I'm going to pressure test the current radiator one more time. If it's leaking, I'll replace it, and test the replacement before I put everything back together....Saturday project.
  2. Mikerizer

    Radiator leak, MAYBE a head gasket problem

    Brand new, out of the box radiator from AZ. And yes, I can see the leak on this one, and a puddle under radiator on the driver's side.
  3. Mikerizer

    Radiator leak, MAYBE a head gasket problem

    NEW radiator. I was unaware of the block tester, which changes fluid from blue to yellow in the presence of exhaust gasses in the radiator. I'm going to try that later today.
  4. Mikerizer

    Heater not blowing hot air SOMETIMES.

    You definitely got me on the right track! I had no idea there even WAS a procedure for that. Thanks so much!!!
  5. Mikerizer

    Radiator leak, MAYBE a head gasket problem

    I should have given more information. Last night I was tired, cold, and frustrated. 1-there is no sign of oil in the coolant 2-there is no sign of coolant in the engine block 3-the motor runs perfectly, and no DTC is present I'm thinking about replacing the radiator, but before I add coolant...
  6. Mikerizer

    Radiator leak, MAYBE a head gasket problem

    The engine was losing coolant, with no visible leak. Had to add coolant at a rate of about a gallon per 20 mile or so trip. I did a pressure test on the system with it cold, and coolant was leaking rapidly from the driver's side of the radiator, about 1/3 ways from the bottom. So, I replace...
  7. Mikerizer

    Heater not blowing hot air SOMETIMES.

    I think this is fixed. I tried the relearn by pulling the fuse, but I'm not sure I was trying the right fuse. I found some instructions in another forum: turn key on with AC on full recirc, then press and hold the recirculate and rear washer buttons at the same time for about 5 seconds until...
  8. Mikerizer

    Heater not blowing hot air SOMETIMES.

    Will try that; thanks! This is the same van that the cruise control was not working for over two years, and I had to disconnect the battery overnight while waiting for an EGR valve to come in (I had to move the alternator to get to it). After that, the cruise started working!
  9. Mikerizer

    Heater not blowing hot air SOMETIMES.

    To preface, there is a coolant leak somewhere, but I haven't had time to do a pressure test. The hoses going into and out of the heater core are hot. Sometimes the interior fan blows hot air, sometimes it's stone cold. Is this likely a blend door problem, and is it actuated by electric motor...
  10. Mikerizer

    2000 Ford Explorer 5.0L Eddie Bauer running rough

    Thanks! God has blessed me indeed! It’s actually my brother’s truck, not my son. Sent from my iPhone using Tapatalk
  11. Mikerizer

    2000 Ford Explorer 5.0L Eddie Bauer running rough

    I’ve gotten the motor mount installed, new plug wires, NOS air duct between air box and throttle body. I cleaned the MAF, and did the computer relearn procedure. It seems to be running pretty well. It still needs some drive time to learn the shift points, etc. Sent from my iPhone using Tapatalk
  12. Mikerizer

    2000 Ford Explorer 5.0L Eddie Bauer running rough

    I got the thread repaired, and the plate installed. Tomorrow is motor mount, plug wires, clean the throttle body, install the air boot, and clear/relearn the computer.
  13. Mikerizer

    2000 Ford Explorer 5.0L Eddie Bauer running rough

    LOL! Makes perfect sense! I'll probably just use lock washers on the nuts, with no thread lock.
  14. Mikerizer

    2000 Ford Explorer 5.0L Eddie Bauer running rough

    My 29/64" hex shank drill bit came in yesterday...going to work on the thread repair tonight. QUESTION: should I use thread lock on the repair kit, on the stud itself, or neither? Thanks, as always, for your advice!
  15. Mikerizer

    2000 Ford Explorer 5.0L Eddie Bauer running rough

    Bought a 7/16" 14 thread repair kit. Going to drill it out and put in a thread insert. Ordered a 29/64" hex shank bit which should be here Friday. I have to use an extension to get to the block, so it has to be a hex shank. Air intake tube and plug wires should be here this week as well.
  16. Mikerizer

    2000 Ford Explorer 5.0L Eddie Bauer running rough

    Yeah, I've got to try to find something tomorrow. Fortunately, I have a straight shot at it, but it's about 18" from hammer to block.
  17. Mikerizer

    2000 Ford Explorer 5.0L Eddie Bauer running rough

    Well, I got one bolt out with an extractor...after I broke an extractor off in the other bolt. The extractor is too hard to drill, and it's the one that's a thread deep into the block. I am NOT a welder, and I don't have a torch. I'm going to buy a dremel tomorrow, and see if I can get...
  18. Mikerizer

    2000 Ford Explorer 5.0L Eddie Bauer running rough

    Well, it's not getting any better. Haven't done much additional troubleshooting, but did confirm that my patchwork on the "Hose-Air" between the MAF and Throttle Body didn't hold. Good news is that I was able to find a part number on it: XL2X-9R. I found one on ebay for about $23...gonna take...
  19. Mikerizer

    2000 Ford Explorer 5.0L Eddie Bauer running rough

    Thanks for all your replies! I'll definitely clean the MAF and intake components as you suggested, and replace the PCV valve. I thought I saw a boot on autozone's website for $75 but can't seem to find it again. When you say "running a combustion chamber cleaner through the whole intake air...
  20. Mikerizer

    2000 Ford Explorer 5.0L Eddie Bauer running rough

    2000 Ford Explorer 5.0L, Eddie Bauer Edition; Automatic 2WD, 247k miles Lots going on here. This my brother's truck, and he's flat broke, so I'm trying to help him out. It was setting P0303, P0171, and P0174. We looked all over for vacuum leaks. I removed the large tube between the MAF and...