Search results

  1. C

    1997 Buick Century 4t65-e no first gear

    I 'fixed' the problem, sold the car as is. thank you guys for the help. It was more of an internal issue and not worth the money for an old car. thanks to all for the advise!
  2. C

    1997 Buick Century 4t65-e no first gear

    thanks for the tip gr!
  3. C

    6.7 RAM soot on air filter?

    thank you dan, I see there is a crankcase filter on top of the 6.7 and to chg it at 67000. ck eng lite will come on at 60 to remind you.
  4. C

    6.7 RAM soot on air filter?

    I've seen dirty but never sooty unless the pvc system was pumping a mist of oil from the crankcase pressure?
  5. C

    6.7 RAM soot on air filter?

    Is the soot from the pvc venting into the air box? and does the 6.7 have a pcv valve that needs changed? thanks jackc
  6. C

    1997 Buick Century 4t65-e no first gear

    thats a good idea, I have hit it there but obviously not hard enough! Its really stuck in place. should I have my floor jack under the ball joint when it pops loose? I have no idea how much tension it has on it? I didnt remove any of the upper strut or bolts no need to bother them so I just want...
  7. C

    1997 Buick Century 4t65-e no first gear

    My thoughts exactly!! I have an air hammer attachment that can hammer for me. I've beat on it all that I dare so plan B tomorrow. thanks gr. since I have the strut and the two adjustment bolts in place, how much tension is actually on the lower control arm? Been a while since I tore down a fwd...
  8. C

    6.7 RAM soot on air filter?

    Had a question on air filter on my '17 RAM. Replaced mopar air filter with the same and noticed the bottom of the air filter is full of greasy soot? Its mostly smeared on the bottom of the pleats and part way up but the top is clean so its doing its job but I was expecting a dirty filter not a...
  9. C

    1997 Buick Century 4t65-e no first gear

    I was hoping so thanks again!! Now if I could just get the lower ball joint apart, not enough room to slip the cv axle out of the tranny unless the tie rod and ball joint is moved. Tie rod popped right off but that ball joint wont budge. Got some penetrating oil on it now. A few good blows on...
  10. C

    1997 Buick Century 4t65-e no first gear

    thanks bp glad you are up and running again. I started on the 1997 4l60 side cover and I have a shop manual saying I have to disconnect the rack and pinion bolt, no big deal but they manual says to disconnect the exhaust?? Also have to disconnect the left side tie rod and lower ball joint. I...
  11. C

    1997 Buick Century 4t65-e no first gear

    Hey bp on this 97 buick w/4t60e I ordered the solonoids and case gasket. Dumb question when you say I need to support the tranny underneath with a jack I'm ok with that, just wonder when I remove the case how much tranny fluid will I loose? I just changed the filter, fluid and reuseable pan...
  12. C

    crank but no start

    +25 is cold enough for me!! -25 is bone chilling..
  13. C

    crank but no start

    thank you nickb2!! cold up there in canada yet??
  14. C

    crank but no start

    yep thats the part that has failed now a third time. wow did they ever charge you to fix it!! that part is around 25-35.00 now and about an hour labor to install. but I know when you go to the dealer its expensive. the first repair about 10 yrs ago cost me that much also. I've had to learn to...
  15. C

    crank but no start

    sound like the same thing thats happening to me. did chevy replace just the key part or the module in the dash also? this car of mine has gone through two of each and now a third!
  16. C

    crank but no start

    have you had troubles with the ign and module?
  17. C

    crank but no start

    the key doesnt have a chip but the ignition key tumbler assembly has a passlock built into it that when installed in switch security module should need a relearn to crank at all. thats why I was leaning toward the ign module having a fault, its happened before. Many gm's of this late 90's early...
  18. C

    crank but no start

    thank billr, its a hard thing to diagnos because when it runs, it runs exc then the next day or so back to nothing. when I have it running the fuel pressure is 48psi, voltage is 14.3 and no check lights. One thing I did notice is the lack of the security icon maybe the bulb to it burned out...
  19. C

    crank but no start

    I've been chasing a ghost on this Impala trying to locate why it runs fine one day and the next it won't start. I checked several things when it ran, fuel pressure/regulator, voltage, etc and no check engine lite either. I decided since I rec'd a replacement ignition key that has the passlock to...
  20. C

    Engine stops running

    that is an absolute awsume article on this subject. I'm going to see if the site will let me print it out!! I imagine thats not a problem. Yesterday I thought that the IAC was the culprit and it started , idled and ran just fine, drove all around the neighborhood within walking distance of my...