Search results

  1. oddone1975

    light issue

    Just ran truck to town and back with no issue so I say this one is fixed
  2. oddone1975

    light issue

    Turns out so far problem was in rear light harnesses moisture was getting in and corroded the connections at plugs cleaned them and packed with dielectric grease see if it holds up so far it's been come warmer dryer weather I'll look at junk yard for better harness
  3. oddone1975

    light issue

    I don't have the stuff to make it or the understanding of it so I'm going to let my mechanic look at it I really thought it might be the switch
  4. oddone1975

    light issue

    Well changed switch this morning and still doing it so it's at the shop he thinks he can get it in this afternoon
  5. oddone1975

    light issue

    Ok now upon replacing fuse as soon as I turn lights on fuse blows so I picked up a new headlight switch and am going to install tomorrow bc and see if it solves issue
  6. oddone1975

    light issue

    Ok I checked the harness in the area that the marker got broke and everything is good but as soon as I start to go it blows fuse sitting still it doesn't blow fuse really strange
  7. oddone1975

    heat issue

    yes t stat was replaced again and as before no foreign matter in it but when sitting idle for a while it will come up to temp no problem but once moving it drops and cools quite a bit but at this point i give up it has some heat you don't roast in it but you won't exactly freeze either so i am...
  8. oddone1975

    light issue

    once i get home tomorrow i am going to check the marker light that i replaced see if maybe i pinched the wire with the J hook chain we used to straighten bumper a bit or if i simply have it installed wrong go from there. and i would need to make something different as my fuse panel is...
  9. oddone1975

    light issue

    It takes few seconds seems to be when I go to move there is no trailer harness had a plug it simple but was messed up
  10. oddone1975

    light issue

    Please fill out the following to ask a question. MAKE:dodge MODEL:ram 1500 4x4 YEAR:1998 MILES:188K ENGINE:5.2 DESCRIBE ISSUE.... got in to a fender bender with snow bank and tweaked front bumper a bit and broke passenger side headlight/markerlight assembly had to retweak the bumper a bit to...
  11. oddone1975

    heat issue

    Have tried everything short of new water pump at this point it's good enough
  12. oddone1975

    heat issue

    Sat on side of Rd helping a motorist and gauge come up to 210°F and heat about cook you out but once moving down Rd it drops it's just really weird I have to see when my guy can swap t-stat out as it's new but suspect it maybe defective out of the box
  13. oddone1975

    heat issue

    That is my impression that t-stat is defective even though it's new that will be the next step
  14. oddone1975

    heat issue

    Only thing he missed was the Cable to switch from defrost to floor to pannel he's going to fix that this week as it's stuck on defrost so my feet are still chilly lol
  15. oddone1975

    heat issue

    Ok heater core finally done what a pain that was! It was severely plugged believe it or not with chunks of permatex from when previous owner did the water pump. However now it's coming up to almost 210°F when sitting idle but once moving drops way down even with radiator still having cardboard...
  16. oddone1975

    heat issue

    Yes I was watching I did not take pics of when it was clamped I have pics of what we used I trust this guy 1000% I used to work for him and he is a straight shooter nothing other than clamping and reversing the heater lines was done
  17. oddone1975

    heat issue

    I am hoping that the heater core maybe the problem seeing as is let go during blocking the upper hose waiting on my guy to get it replaced
  18. oddone1975

    heat issue

    This is what we used to clamp off hose
  19. oddone1975

    heat issue

    I take it to a friend but I didn't get pics of clamp set up by and as of now truck is down waiting to replace heater core as it failed and lately ambient temperature here has been around 10°F or lower but I'm wondering as my heater core feed hose runs directly off water pump and not the...
  20. oddone1975

    heat issue

    But I have to replace the heater core tomorrow as it started leaking