02 Ram P0442

wcadams

Full Member
Joined
Jun 2, 2009
Messages
52
Likes
0
Points
6
#1
we have in the shop and 02 dodge ram 5.9L. p0442 evap medium leak fault set, leak checked evap system with Chrysler eeld no leaks present with smoke. Leak checked with the 5psi air, flow ball dropped to bottom indicating no flow/leaks. Replaced leak detection pump, 100 miles later the same fault code came back. Currently leak checking with no present leaks. Could the fuel cap be the inter. cause? Checked purge duty solenoid, checks ok. Has anyone had this issue and might be able to help us out.
thanks in advance will
 

wcadams

Full Member
Joined
Jun 2, 2009
Messages
52
Likes
0
Points
6
#2
I also removed the charcoal canisters, shook the heck out of them and didn't see any charcoal fall out
 
Joined
Nov 14, 2006
Messages
4,853
Likes
51
Points
48
Age
118
#3
some POSSIBLE CAUSES
EVAPORATIVE EMISSION LEAK DETECTION........ you covered this with smoke
EVAP PURGE SOLENOID LEAKS/STUCK OPEN....... could be a intermittant*..
INTERMITTENT LDP MONITOR FAILURE....... I think you replaced LDP... BUT
With the DRBIIIt in System Tests, perform the LDP Monitor Test. This will force the
PCM to run the LDP Monitor. results were, pass - fail?

And then a YES to the gas cap.. use only OEM..
I will check for TSB's

* anything in the freeze frame - ie VSS, MAP, ECT, and Load.
 

wcadams

Full Member
Joined
Jun 2, 2009
Messages
52
Likes
0
Points
6
#5
thanks, no other fault codes or issues. I ran the LDP monitor test numerous times passing them all.
 
Joined
Nov 14, 2006
Messages
4,853
Likes
51
Points
48
Age
118
#7
2 things that have 'got' me before were - small leak top of tank... and a leak at the service port, would NOT show up with EELD or smoke attached .... will addd some thoughts later