03 Impala 3.8L hole in upper intake

Joined
Jul 16, 2017
Messages
69
Likes
1
Points
8
#1
So the other day had an 03 Impala come in w/customer complaining about rough start and lack of power when it did finally start. Upon inspection found hole in upper intake behind t-body where electrical harness runs. Was wondering if anybody has seen this b4? has me baffled on as to how it could have gotten there.

Sent from my SAMSUNG-SGH-I747 using Tapatalk
 
Joined
Jul 16, 2017
Messages
69
Likes
1
Points
8
#5
So culprit found: catylitic convertor was plugged causing excessive heat on upper plenum thru egr tube, burning a hole completely through plenum. Unfortunately the car has California emissions so convertor cost an arm & a leg (thats even a universal weld in). But got it all taken care of: new plenum and new convertor and she's purring like a kitten again.
 

EricC

Hero Member
Joined
Nov 14, 2006
Messages
424
Likes
3
Points
18
Location
Tulsa, OK
Website
facebook.com
#6
So culprit found: catylitic convertor was plugged causing excessive heat on upper plenum thru egr tube, burning a hole completely through plenum. Unfortunately the car has California emissions so convertor cost an arm & a leg (thats even a universal weld in). But got it all taken care of: new plenum and new convertor and she's purring like a kitten again.
I hope you did some digging into the root cause of that converter failure. If not, you may see this one again.
 
Joined
Jul 16, 2017
Messages
69
Likes
1
Points
8
#7
Yes EricC, found 4 ripped injector o-rings in process, customer changed maf trying to kill po171 & po174 codes previous to this situation also