07 Pont Vibe Transmission Valve Body

Discussion in 'Transmission Forum' started by ScottVA2775, Feb 26, 2017.

  1. ScottVA2775

    ScottVA2775 Newbie

    Joined:
    Aug 7, 2016
    Messages:
    7
    Likes Received:
    0
    Gender:
    Male
    MAKE: Pontiac
    MODEL: Vibe
    YEAR: 2007
    MILES: 135K
    ENGINE: 1.8L
    DESCRIBE ISSUE....So, I needed to replace my TCC Solenoid on this car and in order to do so, you have to get to it through the pan and remove the valve body. When I finally got the valve body out, a little plastic black piece with a metal ball on the end and a small spring popped out and I can't figure out where it came from. See pic. Can anyone please let me know where this thing goes so I can put this car back together??? Apparently there are 2 different transmissions for this year car. One has an 18 bolt pan and the other has 19 bolts. Mine is the 18 bolt pan
     

    Attached Files:

  2. billr

    billr wrench Staff Member

    Joined:
    Mar 12, 2007
    Messages:
    5,646
    Likes Received:
    55
    I sent PM to one of our trans experts, let's hope he joins in here tomorrow.
     
  3. bp042665

    bp042665 hunting nut

    Joined:
    Nov 26, 2012
    Messages:
    532
    Likes Received:
    8
    Gender:
    Male
    Location:
    Iva South Carolina
    Hi all that it the drain back ball and spring it goes in the case sping up and the ball sits in the valve body plate
     
  4. ScottVA2775

    ScottVA2775 Newbie

    Joined:
    Aug 7, 2016
    Messages:
    7
    Likes Received:
    0
    Gender:
    Male
    Thank you BP. Can you give me an idea of where it goes in the case? I've looked and can't figure it out. If you have a diagram that would help even more.

    Thank you
     
    Last edited: Feb 27, 2017
  5. bp042665

    bp042665 hunting nut

    Joined:
    Nov 26, 2012
    Messages:
    532
    Likes Received:
    8
    Gender:
    Male
    Location:
    Iva South Carolina
    i have looked for a picture but cant find 1but its right by the servo just in front of them. if you take a picture ii can help you out
     
  6. ScottVA2775

    ScottVA2775 Newbie

    Joined:
    Aug 7, 2016
    Messages:
    7
    Likes Received:
    0
    Gender:
    Male
    I ended up taking the day off work yesterday and went to the dealer to ask. One of the mechanics came back with a diagram that showed vaguely where it goes and suggested I get some assembly goop to hold it in place while I installed the valve body. I got everything back together and took it out for a drive last night and everything seemed ok. This morning, my father took it out to put some miles on it for emissions testing and the CEL came back on. I just scanned it and it's the same damn number- P0741. I saw some people over on the GenVibe forums talking about a TSB or Recall about the ECU setting this code and the fix was to replace the ECU. Have you guys heard about this? Do you have any other ideas what it could be? I made sure the solenoid was installed properly and I double checked the connectors before I closed everything up. (I took a picture of the connectors before I disconnected them to make sure I put the right ones back where they're supposed to go). I may have to have my father take it to a tranny shop to fix it since I don't have the funds to do it myself.

    Thanks for all your help
    ScottVA
     
  7. bp042665

    bp042665 hunting nut

    Joined:
    Nov 26, 2012
    Messages:
    532
    Likes Received:
    8
    Gender:
    Male
    Location:
    Iva South Carolina
    well scott i have had this problem before and had to replace Valve Body also computer
     
  8. ScottVA2775

    ScottVA2775 Newbie

    Joined:
    Aug 7, 2016
    Messages:
    7
    Likes Received:
    0
    Gender:
    Male
    Just talked to the dealer. They want just shy of $6000 to put in a reman trans. I just had to laugh. I'll take it to a transmission shop across the street and see what they say.
     

Share This Page