4L60 seems to slip at high speeds and no reverse forward at start up

Discussion in 'Transmission Forum' started by ivane21, Aug 15, 2016.

  1. ivane21

    ivane21 Full Member

    Joined:
    Dec 31, 2007
    Messages:
    126
    Likes Received:
    0
    Gender:
    Male
    Occupation:
    Sales and Purchasing Manager, Mechanic,
    Location:
    Brooklyn Center, MN
    Wow, I feel like I'm right in the shop with you guys...Thanks for all the "hand holding" here...I do need it when it comes to these things...

    I always get leary messing with valve bodies, worried I'll unbolt the wrong thing and a bunch of check balls will go everywhere and never get back in the wright places...or something like that.

    Maybe I'll make a youtube video when I do this. I've got plenty to do now, and while I've got the Snap-On Ethos borrowed from a friend maybe I can drive and see the TCC as suggested too...not sure if I can actually "command" it on and off with that tool, but I'll be messing around with it alot. I'll be sure and give some updates. I've got a good feeling on the updated valve body as suggested.

    Again you guys are great, I'll be sure and pay this forward!

    Thanks,
    Ivan
     
  2. billr

    billr wrench Staff Member

    Joined:
    Mar 12, 2007
    Messages:
    5,802
    Likes Received:
    57
    If I have to replace my VB, I'll get one from Central Valve Bodies in Tulsa, OK.
     
    ivane21 likes this.
  3. bp042665

    bp042665 hunting nut

    Joined:
    Nov 26, 2012
    Messages:
    550
    Likes Received:
    9
    Gender:
    Male
    Location:
    Iva South Carolina
    yes bill thats who i use they are great at what they do i have never had a bad 1 in 8 years useing them there # 1-877-341-0266
     
    ivane21 likes this.

Share This Page