96 Chev K1500 350 Vortec Will Not Start and Backfires

Joined
Jan 13, 2018
Messages
1
Likes
0
Points
1
Age
43
#16
I have a 1997 k1500 with a 5.0 litre and it was on a crank and no start. It would backfire thru the carb but wouldnt start. I replaced the cap and rotor and fuel filter and it started right up... I hope this helps people with a chevy truck. Cause that is the usual cause. If you spray starting fluid in it and it doesnt start its not the fuel pump. I have a 2005 chevy van with a 4.3 litre and it was exactly the same problem. Same fix.. Runs great.. So please try that first
 

nickb2

Wrench. I help when I can
Joined
Nov 22, 2008
Messages
8,143
Likes
122
Points
63
Location
St-Hyacinthe, Quebec, Canada
#17
I almost choked on my beer seeing these old threads.

Yeah, a 5.0l in a GM, that must be a typo. But yes they did make those engines. Great in a ford, but not so much in a GM.

I miss transman and NickD. They added flavor to this site.

I guess that's part of getting old. Like this thread.
 

jd

Hero Member
Joined
Jan 14, 2007
Messages
462
Likes
19
Points
18
#18
The 5.0 GM engine found its way into some boats. Mostly Inboard/Outboards as I recall. In MerCruiser, that made a 3.0 (special version of the 2.5 "Iron Duke" 4-cyl) a 4.3 V6 (we know about those!), then the 5.0 V8 and the 5.7/350 V8. The 4.3 V6 was turned up to nearly the HP of the 5.0, and the 5.0 didn't have the torque of the 5.7. Result? 5.0 dropped from MerC's new and reman product lines. Best part of 5.0 was it used many of the same marine exhaust parts as the 5.7, and those V8 parts are a lot LESS expensive than V6 parts.