crank no start f150

Joined
Apr 23, 2018
Messages
9
Likes
0
Points
1
#1
i have a 99 f150 that i removed the dash cluster and now it will not start...i replaced fuel pump and filter not realizing that was not the proble...i am getting spark and fuel to the rail but it just wont start unless i spray starter fluid in intake and shuts right off
 
Joined
Apr 23, 2018
Messages
9
Likes
0
Points
1
#2
i am pulling my hair out trying to figure this thing out so plz any suggestions would be great...thanks
 
Joined
Nov 14, 2006
Messages
1,497
Likes
15
Points
38
Location
Nothern California
#3
From what you tell us, (unless i spray starter fluid in intake) you still do not have fuel even though you replaced the pump and filter.

What is the fuel pressure spec at the rail and are you meeting that spec?
 
Joined
Mar 1, 2002
Messages
3,380
Likes
43
Points
48
Location
Kentucky
#4
Why did you remove the cluster? How the cluster working now? What symptoms led you to decide to replace the pump? Do you have power at the injectors? Do you have a scanner?
 
Joined
Apr 23, 2018
Messages
9
Likes
0
Points
1
#5
Removed the cluster because the odometer isn't working and watched a video on resoldering a cracked solder which did not work and when I put it back together it started the first two times I tried but shut right off and if I wait an hour or so to crank it it fires up but dies out...I changed the fuel pump because I had similar problems with my other truck recently and it was the fuel pump and yes there is power to the injectors and no scanner...the cluster seems to be fine except for the odometer and I think the gas gauge isn't working but I'm really not sure if it reads if the truck isn't running...no fuel pressure gauge but when I turn the key on I do hear the pump coming on and if I hit the valve stim on the rail gas sprays out...when I took the cluster back out to see if maybe I screwed something up I noticed I soldered two separate solders together so is it possible I have shorted my cluster out
 
Joined
Apr 23, 2018
Messages
9
Likes
0
Points
1
#6
Couldn't hear the original pump coming on and when I pulled it and hooked it to the battery it was about dead and looked pretty old
 
Joined
Apr 23, 2018
Messages
9
Likes
0
Points
1
#7
Haven't had the truck long and it ran pretty good before I messed with it and there's no doubt it's something I've done but I just need to figure it out we have 6 kids and we both work so one vehicle isn't working all that great
 
Joined
Mar 1, 2002
Messages
3,380
Likes
43
Points
48
Location
Kentucky
#8
Look at this info I found about anti-theft...

This is the question...
To start its a 99 f150v6. I've been reading on my issue for about a week and it seems to me that its the pats anti-theft system..

What happens is most of the time it starts right up. The security light will blink and I then know it will start. When it doesn't start the security light stays on about 5 seconds when ignition is in the on position. From what I've read that means there is a possible issue with the module.

I have a few questions on this. Is the module located in the kick panel on the driver side? I pulled it off and noticed 2 sets of wires going to what looks like maybe 2 modules or connectors.

This is the answer...
I honestly don't know how you'd bypass it... from what I understand the PATS system also runs through the cluster, you can't put in a new cluster without having the dealer VIN match it to your vehicle. There's lots of elements to the system... I'm curious as to if you can get around it at all
 
Joined
Mar 1, 2002
Messages
3,380
Likes
43
Points
48
Location
Kentucky
#10
Is the theft light "on the cluster" and not on top of the dash or elsewhere? Have you checked all fuses? Any other cluster lights that should come on but don't come on? Might be helpful if we could identify specifically the function of the circuits that were soldered together (shorted).
 
Joined
Apr 23, 2018
Messages
9
Likes
0
Points
1
#11
The circuits I soldered together is for the odometer and the theft light is on the cluster and I'm pretty sure all the other lights on it still work