mazda 2000 millenias code:P0170 &P0173

Joined
Jan 17, 2009
Messages
4
Likes
0
Points
0
#1
Hi I have Mazda 2000 Millenia s 2. 3 liter 135,500 mile
check engine was on Code read is P0170 &P0173 (Fuel tream bank 1 & fuel tream bank 2 malfuntion) . every body help me what can I do for fix the problem . I don't known where I started to do
Thank verry much
John
 
Joined
Nov 17, 2006
Messages
4,461
Likes
5
Points
38
Location
Portland,Oregon
#2
How does it run?...Does it have a miss?...when was it tuned up?....plugs,wires.fuel filter....Jim
 
Joined
Jan 17, 2009
Messages
4
Likes
0
Points
0
#3
Jim Fairbanks said:
How does it run?. . . Does it have a miss?. . . when was it tuned up?. . . . plugs,wires. fuel filter. . . . Jim
thank you for reply
the vehicle run good (look like before check engine on ) not miss fire , I did tuned up when did timming belt (90,000 mile ) changeg spark plugs wire set . I have change fuel fillter when light was on but later light on again
thank `
 
Joined
Jan 17, 2009
Messages
4
Likes
0
Points
0
#5
Jim Fairbanks said:
Did you have the codes reset with a scanner?. . If not try having them reset and see if the same codes come back. . . Jim
yess Jim I clear trouble code check engine off and after some day engine
on and same code P0170&P0173 appeared
john
 
Joined
Nov 20, 2008
Messages
9
Likes
0
Points
0
#6
Your 2. 3 engine is the miller cycle correct? If so there are plastic vacuum T's that crack and break causing a vacuum leak and the codes you have. Of course they are located underneath the intake manifold and not visible unless you remove the manifold. At the dealership we used to monitor the front o2 sensors with a scan tool and if they are both flat or nearly so ( at idle) then spray some good ole' Carb cleaner under the intake and see if the o2's start to respond. If they do you have cracked vacuum T's. If not, you may need 2 new 02 sensors (if they are original) thats a lot of miles you have there . Good luck, hope this helps Karl