No reverse and forward doesn't move till 2300 rpm

Joined
Sep 5, 2018
Messages
10
Likes
0
Points
1
Location
Mecca, indiana
#16
It comes on yes. I cleared the two codes, p506 and p0128. Light stayed off for a little bit and the p506 code came back so I believe it's communicating just not what I'm looking for
 

bp042665

hunting nut
Joined
Nov 26, 2012
Messages
612
Likes
11
Points
18
Location
Iva South Carolina
#18
machanical failer wont set a code in this transmission like i mention earlyer i see this alot most likely its a clutch problem in the 3/4 clutches that why it pulls hard and no reverse
 

billr

wrench
Staff member
Joined
Mar 12, 2007
Messages
6,139
Likes
65
Points
48
#19
This all seems pretty weird. It would be so easy for the PCM to monitor turbine speed, VSS, and "gear commanded" (what solenoids have been energized) and check if the math works out. If not, then set the P1870 that indicates something is slipping; like mine does. Likewise, comparing engine rpm to turbine speed, accounting for TCC commands, will easily identify if TC slip is out of expected range. I'm not saying BP or anybody else is definitely wrong about this, but I sure want us to keep considering all options for a while.
 
Joined
Sep 5, 2018
Messages
10
Likes
0
Points
1
Location
Mecca, indiana
#20
My current financial situation isn't allowing me to take any action for next couple weeks but I'm afraid of something bigger happening if I keep driving it the way it is. Like I stated earlier the drag was 3rd gear being enplace of 1st, when I drop it into D it automatically goes to 3rd gear and that is confusing me as to how the computer isn't registering that but it physicly is switching. Once up to about 40 mph 3rd feels correct and shifts to 4th like normal. My trans temp didn't go over 176 on the 6 mile drive home last night. I'm still figuring out what sensors and activities Torque moniters.If you know any different programs, obd2 readers for the kiwi Bluetooth , that will map it better I'm open for sugestions. Im still figuring what more I can get from the Torque program and I'm grateful for the advice and help. Thank you guys
 

billr

wrench
Staff member
Joined
Mar 12, 2007
Messages
6,139
Likes
65
Points
48
#21
I can't help you with that Torque, but expect that using it for live-data will give some valuable clues, so keep learning about it.
 

grcauto

Hero Member
Joined
May 29, 2014
Messages
258
Likes
15
Points
18
#22
The system should set a code
My current financial situation isn't allowing me to take any action for next couple weeks but I'm afraid of something bigger happening if I keep driving it the way it is. Like I stated earlier the drag was 3rd gear being enplace of 1st, when I drop it into D it automatically goes to 3rd gear and that is confusing me as to how the computer isn't registering that but it physicly is switching. Once up to about 40 mph 3rd feels correct and shifts to 4th like normal. My trans temp didn't go over 176 on the 6 mile drive home last night. I'm still figuring out what sensors and activities Torque moniters.If you know any different programs, obd2 readers for the kiwi Bluetooth , that will map it better I'm open for sugestions. Im still figuring what more I can get from the Torque program and I'm grateful for the advice and help. Thank you guys
Can you see what the range sensor is doing?
 
Joined
Sep 5, 2018
Messages
10
Likes
0
Points
1
Location
Mecca, indiana
#23
It wasn't transmitting a signal on the input sensor only output and it finally threw a code relevant to the transmission P0756. According to the data it's shifting through all the gears but I can't feel a single change until about 45-50 mph. I'm going to pull the trans and find out what is actually wrong and rebuild it but in the meantime I was told I could have a transmission from a 08 Colorado that someone removed to do a ls swap. Besides for probably having to change the bell housing is it compatible ?
 
Last edited: