P0420

Discussion in 'Import Vehicles' started by dabunk, Jan 14, 2017.

  1. nickb2

    nickb2 Wrench. I help when I can

    Joined:
    Nov 22, 2008
    Messages:
    7,731
    Likes Received:
    113
    Gender:
    Male
    Occupation:
    Diagnostic tech
    Location:
    St-Hyacinthe, Quebec, Canada
    Wow, I am way late responding to this thread, completely forgot about it. Sorry.

    @dabunk, this is more and more looking like a cat problem. You say up and down stream o2s are new, still coding, right?

    When fuel trims are as you say, they are not ok, the only thing left, is either a exhaust leak or a bad cat. If your secondary o2 is not switching like it should and its new, yup, bad cat.

    Hope that helps.

    Here is a PDF anyway for you the help you along if you doubt the catalyst.
     

    Attached Files:

    Last edited: Feb 8, 2017
  2. nickb2

    nickb2 Wrench. I help when I can

    Joined:
    Nov 22, 2008
    Messages:
    7,731
    Likes Received:
    113
    Gender:
    Male
    Occupation:
    Diagnostic tech
    Location:
    St-Hyacinthe, Quebec, Canada
    The TSB Kev2 gave is very precise, and if you follow the above PDF, there can only be one conclusion, bad cat.

    Do you have a laser temp probe? That would help diagnose a bad cat.

    If you don't have one, they are cheap and a very essential tool for your tool box.

    Watch this video.

     
  3. kev2

    kev2 wrench

    Joined:
    Nov 14, 2006
    Messages:
    4,648
    Likes Received:
    38
    Gender:
    Male
    OK you installed new o2 sensors ( they are not AF sensors?) and a new cat?

    the scan details are missing but I am agreeing that the cat is not getting hot enough* - how is ECT - FT's , front o2 sensor should swing (.3-.7) but rear should be fixed @.5-.7
    The cold start comment setting code has me thinking temp - ECT , overly rich, at start

    *Did I read something in TSB about cat temp...
     
  4. Gerald Handt

    Gerald Handt Newbie

    Joined:
    Oct 27, 2016
    Messages:
    11
    Likes Received:
    0
    Gender:
    Male
    I'm having the same problem with a 01 acura integra 1.8, 163,000 miles. This car is running great but I have a rattle in the exhaust that sounds like marbles banging around in there. Does this mean the cat converter is shot?
     
  5. dabunk

    dabunk wrench

    Joined:
    Nov 14, 2006
    Messages:
    1,389
    Likes Received:
    9
    Gender:
    Male
    Location:
    Mine Hill, New Jersey
    Home Page:
    Brand new cat and O2 sensors and getting same as before the change. I am looking at monitoring engine coolant temp it seems to go cool aftr it sits for a few minutes. I followed the TSB posted and it still not pass but I am thinking it is getting to cold to pass.
     
  6. nickb2

    nickb2 Wrench. I help when I can

    Joined:
    Nov 22, 2008
    Messages:
    7,731
    Likes Received:
    113
    Gender:
    Male
    Occupation:
    Diagnostic tech
    Location:
    St-Hyacinthe, Quebec, Canada
    That is a very reasonable assumption. I would certainly check that out. I think you are the right track now.

    ;)
     
  7. kev2

    kev2 wrench

    Joined:
    Nov 14, 2006
    Messages:
    4,648
    Likes Received:
    38
    Gender:
    Male
    can y0u tell us some findings ECT, FT's , the pre and post cat voltages - graphs- but that is a lot to ask.

    I have to ask - is there still a supply of OEM Suzuki parts?

    Maybe if we cannot correct the issue we will can follow Richard Petty advice " Cheat neat".
     
  8. nickb2

    nickb2 Wrench. I help when I can

    Joined:
    Nov 22, 2008
    Messages:
    7,731
    Likes Received:
    113
    Gender:
    Male
    Occupation:
    Diagnostic tech
    Location:
    St-Hyacinthe, Quebec, Canada
    As for this comment, if you can hear marbles in the cat, that is for sure something wrong there.
     
  9. nickb2

    nickb2 Wrench. I help when I can

    Joined:
    Nov 22, 2008
    Messages:
    7,731
    Likes Received:
    113
    Gender:
    Male
    Occupation:
    Diagnostic tech
    Location:
    St-Hyacinthe, Quebec, Canada
    Shot? yes, like when the guy's tell me to look for buckshot on the birds they kill.
     
  10. dabunk

    dabunk wrench

    Joined:
    Nov 14, 2006
    Messages:
    1,389
    Likes Received:
    9
    Gender:
    Male
    Location:
    Mine Hill, New Jersey
    Home Page:
    Got thermo installed today and now temp stays constnt while idling at 165. Tomorrow will take it out and use the TSB to see if I can get the parameters to set
     
  11. nickb2

    nickb2 Wrench. I help when I can

    Joined:
    Nov 22, 2008
    Messages:
    7,731
    Likes Received:
    113
    Gender:
    Male
    Occupation:
    Diagnostic tech
    Location:
    St-Hyacinthe, Quebec, Canada
    I am guessing "thermo" means ECT?

    Well if this is the case, and everything is staying constant, you got that one fixed Dabunk. I am pretty sure with all the new stuff you put on the car, we can be sure this will be a fixed thread.

    Good on you.;):bat:
     
    Last edited: Feb 20, 2017
  12. dabunk

    dabunk wrench

    Joined:
    Nov 14, 2006
    Messages:
    1,389
    Likes Received:
    9
    Gender:
    Male
    Location:
    Mine Hill, New Jersey
    Home Page:
    Well some improvement but not solved. With new thermostat ECT stays at 195 F constantly. So took it for a drive per the TSB. Finally got the Cat readiness test to pass but on driving home the CEL came back on with the P0420 cude again. Tomorrow will have to take it for another drive after I clear the code and monitor all the other parameters in the TSB. More fun
     
  13. kev2

    kev2 wrench

    Joined:
    Nov 14, 2006
    Messages:
    4,648
    Likes Received:
    38
    Gender:
    Male
    Did miss a post - what are the o2 readings looking like
    Pre cat - and hi or rich readings?
    post cat - fixed and at what?
     
  14. dabunk

    dabunk wrench

    Joined:
    Nov 14, 2006
    Messages:
    1,389
    Likes Received:
    9
    Gender:
    Male
    Location:
    Mine Hill, New Jersey
    Home Page:
    pre cat bouncing from -1 to 2 at idle post cat 4 to 5 at idle ect 195
     
  15. kev2

    kev2 wrench

    Joined:
    Nov 14, 2006
    Messages:
    4,648
    Likes Received:
    38
    Gender:
    Male
    The pre cat is showing - negative voltage? or is it fixed @.1 to .2 that would be a problem if that low..

    should be switching @ .3 to .8 volts
     

Share This Page