Tps problem

GMC guy

Hero Member
Joined
Feb 16, 2008
Messages
327
Likes
0
Points
16
#1
Please fill out the following to ask a question.

Pontiac :
Wave
2006
130k
2L auto tranny
Car stalls at lights. Start, and runs ok, then stalls again.
 

billr

wrench
Staff member
Joined
Mar 12, 2007
Messages
6,138
Likes
65
Points
48
#2
Does it have a proper "fast idle" when started cold? I'm wondering about the IAC system.
 

nickb2

Wrench. Diagnostic Tech.
Joined
Nov 22, 2008
Messages
8,737
Likes
150
Points
63
Location
St-Hyacinthe, Quebec, Canada
#3
Hi gmc guy.

Are you sure it is a 2l in that wave?

Can you pull codes? If the car stalls like you describe. Possibly a large vacuum leak.

As Billr said, check the IAC.

The IAC on this 1.6l (which is the only engine made for the wave) uses a stepper model.
 

nickb2

Wrench. Diagnostic Tech.
Joined
Nov 22, 2008
Messages
8,737
Likes
150
Points
63
Location
St-Hyacinthe, Quebec, Canada
#4
These cars are notorious for bad ECU grounds.

Also, do a idle relearn. Egr can also cause idle stalling when foot off pedal. Check for carbon build up there which may cause poor seating and large vac loss.

Lest not forget, it is a korean badges daiwoo.

Also, this engine uses a variable intake manifold system.
 
Joined
Nov 14, 2006
Messages
4,802
Likes
50
Points
48
Age
118
#5
As mentioned confirm this is a 2.0L - I show a 1.6L only...

Why do you think this is a TPS issue? Something not mentioned ?

I agree - Fuel injectors and the mentioned carbon build up..
But I suspect there will be codes - scan even if CEL is off.
 
Last edited: