Recent content by Mealticket

  1. M

    P1698 No CCD Bus Messages Received, Instr Cluster Not Functioning '98 Chrysler Minivan

    Perspective...I remember buying a '96 Caravan with a bad tranny from a kid and his mom. Poor guy was driving over the Bay Bridge for kidney dialysis, and the mom was about to donate one of her kidneys to him. He just really needed that tranny to go out on top of everything else. They even towed...
  2. M

    P1698 No CCD Bus Messages Received, Instr Cluster Not Functioning '98 Chrysler Minivan

    Glad she's ok. Makes the fact that I am now in OBD monitor hell again seem insignificant, MT
  3. M

    P1698 No CCD Bus Messages Received, Instr Cluster Not Functioning '98 Chrysler Minivan

    Yeah, so I guess unless the system looks and decides the VIN in the BCM doesn't match, I should be good. I assume the VIN is stored there? I don't think I've ever seen this clearly documented, more like 'tribal knowledge'. Like 'you will have to program that. You know that, right?' Well, I don't...
  4. M

    P1698 No CCD Bus Messages Received, Instr Cluster Not Functioning '98 Chrysler Minivan

    Bingo! Checked a Pick 'N Pull about an hours' drive from here this am, and they had two BCMs with my P/N. Pulled the one out of a base model '98 identical to mine, plugged it in, and all is good. It even runs the tach. I kind of thought it would, because the donor had a tach with red...
  5. M

    P1698 No CCD Bus Messages Received, Instr Cluster Not Functioning '98 Chrysler Minivan

    I don't know if my scanner is reading anything but the ECM, but if I go to scan instead of OBD, I see the P1695, no messages from BCM. The P1698 shows under the normal OBD. This is a base model Voyager and I don't think it has any security features needing programming. MT
  6. M

    P1698 No CCD Bus Messages Received, Instr Cluster Not Functioning '98 Chrysler Minivan

    The battery is new, plus I charged it for two hours when I brought it home until my charger showed full charge. Re: BCM, I think I may have a chance if I get a used on as long as the P/N matches. When you say J2534 time, do you mean some kind of pass-through device to program it? I have not been...
  7. M

    P1698 No CCD Bus Messages Received, Instr Cluster Not Functioning '98 Chrysler Minivan

    To clarify, voltage was around 1 with cluster connected or not, with BCM disconnected. ECU was always plugged in during these tests, so a terminating resistor was in the circuit. D.
  8. M

    P1698 No CCD Bus Messages Received, Instr Cluster Not Functioning '98 Chrysler Minivan

    Disconnecting ICM didn't change it, plus I tried the other cluster I have. No change. MT
  9. M

    P1698 No CCD Bus Messages Received, Instr Cluster Not Functioning '98 Chrysler Minivan

    Did the voltage tests at the DLC per Nickb2's recommend, and got like .45 to .50 at both 3 & 11, then with BCM disconnected, I got like .80 to 1.1. This was with ECU connected. Disconnecting other modules didn't cause the .50. So I don't know why these seem to be like 1/2 of the 2.5V voltage...
  10. M

    P1698 No CCD Bus Messages Received, Instr Cluster Not Functioning '98 Chrysler Minivan

    Ok, good continuity on the SCI circuit between TCM and ECU, and no short to ground. Looked for a BCM today at the local Pick 'N Pull yard but the only manual window/door lock vehicle didn't have the same P/N and it had a 4 cyl in it so that might be why. Have to look at other yards next week...
  11. M

    P1698 No CCD Bus Messages Received, Instr Cluster Not Functioning '98 Chrysler Minivan

    Hmm...checked those circuits listed in the procedure, and CCD lines, but not the SCI line. Guess I should. Thanks, MT
  12. M

    P1698 No CCD Bus Messages Received, Instr Cluster Not Functioning '98 Chrysler Minivan

    Thanks for the ideas and kind words, nickb2. I don't have any experience on these data bus systems. I'll run that voltage test at the DLC and advise back, MT
  13. M

    P1698 No CCD Bus Messages Received, Instr Cluster Not Functioning '98 Chrysler Minivan

    I used the FSM wiring diagram and checked continuity between modules. Then I unplugged all the modules and tested for continuity to ground, and found none. Also testing pins 3 & 11 at the DLC, I got 60 ohms with both terminating resistor modules connected, then disconnected the instrument...