Search results

  1. Jim Fairbanks

    Abs speed sensors

    The left and right do have different part numbers...Left is 15176997....Right is 15176998....that is the factory part numbers....Jim
  2. Jim Fairbanks

    2004 nissan xterra,3.3,runs fine until I get it on the freeway and it loses throttle response

    ok...it is fixed.....I found a link that said to reset the ecm....It was something like turn on ign,pump acc 5 times wait 7 sec., hold acc down for 10 sec., up for 10,then down for 10 m,and after I did that the speedo started working and the car ran fine...weird......thanks for all the help....Jim
  3. Jim Fairbanks

    2004 nissan xterra,3.3,runs fine until I get it on the freeway and it loses throttle response

    Hey Dan...the VSS does nothing....yes, I cleared the knock sensor code and right after it came back the truck started doing it's thing...lol...Jim
  4. Jim Fairbanks

    2004 nissan xterra,3.3,runs fine until I get it on the freeway and it loses throttle response

    ok...so I went on the freeway again and it crapped out so I put it in neutral, turned the key off/on and started it ,put it in gear and it drove fine all the way home...hey Bill..I wasn't watching it when it happened...Jim
  5. Jim Fairbanks

    2004 nissan xterra,3.3,runs fine until I get it on the freeway and it loses throttle response

    The coolant and tranny fluid look fine...time for another test drive...Jim
  6. Jim Fairbanks

    2004 nissan xterra,3.3,runs fine until I get it on the freeway and it loses throttle response

    Yeah, Jack,I was wondering if one of those was causing my problem...that is why I mentioned them...I don't know either...Dan, I will try the key thing when it does it and let you know...thanks...Jim
  7. Jim Fairbanks

    2004 nissan xterra,3.3,runs fine until I get it on the freeway and it loses throttle response

    ok,so I just took it out again....drove fine on the city streets,I punched it and it took off fine,no problem...Got on the freeway and after only about 1/2 mile going at steady speed it felt like it just died...I let off the gas and it idles fine. I punched it and all it did was rev between 1500...
  8. Jim Fairbanks

    2004 nissan xterra,3.3,runs fine until I get it on the freeway and it loses throttle response

    ok...I just took it out and ran it from a dead stop to about 60 mph(just guessing the speedo doesn't work).It ran fine but I know as soon as I get on the freeway it will do it again..fuel trims were all about 0...timing was advanced 24 degrees at WOT..I got on a straight road and stopped and...
  9. Jim Fairbanks

    2004 nissan xterra,3.3,runs fine until I get it on the freeway and it loses throttle response

    I am not sure...I will check and let you guys know...thanks...Jim
  10. Jim Fairbanks

    2004 nissan xterra,3.3,runs fine until I get it on the freeway and it loses throttle response

    Hey guys..this thing is weird...it runs fine until I get it up to about 50 mph then there is no throttle response...I can give it gas or let of and try again and it won't go over 1500 rpm..I get back off the freeway and nurse it along and finally it gets normal again....then runs fine until I...
  11. Jim Fairbanks

    2011 chevy silverado 2500HD 6.6 duramax diesel won't start

    ok. I found the valve to bleed it and got the air out....also found the problem why it wouldn't start...This stupid thing has something added on called a fast system. After dropping the tank and replacing the module which was not the problem,I found a relay under the hood with a loose connection...
  12. Jim Fairbanks

    2011 chevy silverado 2500HD 6.6 duramax diesel won't start

    ok...I found the valve to bleed the air...I will try that....Jim
  13. Jim Fairbanks

    2011 chevy silverado 2500HD 6.6 duramax diesel won't start

    how do i get the air out?...someone said the is a button under the hood I have to pump...I don't know where it is...sorry I am not a diesel guy..lol...thanks...Jim
  14. Jim Fairbanks

    2011 chevy silverado 2500HD 6.6 duramax diesel won't start

    I am not a diesel guy just helping a friend and I am confused..lol.He has a 2011 2500HD 6.6 and it won't start..I thought it had a fuel pump in the tank but I think it is just the sending unit..not sure..I know it has an injection pump on the intake but I can't figure this thing out...I dropped...
  15. Jim Fairbanks

    2012 vw Passat door locks not working

    yes..the module is in the drivers door....I checked the wiring and it is ok...also it came from the donor door. thanks ...Jim
  16. Jim Fairbanks

    2012 vw Passat door locks not working

    Thanks Bill...I appreciate it....Jim
  17. Jim Fairbanks

    2012 vw Passat door locks not working

    If you have a diagram of where the fuses are it would help because they are not numbered so I can't tell which one is #1 and so on...Jim
  18. Jim Fairbanks

    2012 vw Passat door locks not working

    By the way....I don't know if I told you but it keeps blowing one fuse...that is why I need to know which one it is...no diagram on the lid...Jim
  19. Jim Fairbanks

    2012 vw Passat door locks not working

    Hey Nick....It is a 2.5 ..VIN3...automatic....Thank you...Jim....and thank you for your friendship...
  20. Jim Fairbanks

    2012 vw Passat door locks not working

    Hey Nick....If you get a chance would you please look up a diagram of the underhood fuse box for me...thank you...I appreciate the help....Jim