Search results

  1. R

    I'm stumped - '93 Ford E350 lurching under load (Motorhome)

    Thanks for the follow-ups...Yes, I have the E40D transmission and I will check the wiring harness. I don't remember, but I'm pretty sure my lurching problems preceded my changing the transmission fluid. I will definitely check the wiring there though... It has been so hot here that I haven't...
  2. R

    I'm stumped - '93 Ford E350 lurching under load (Motorhome)

    So, it looks like the MAP sensor is OK? Right?
  3. R

    I'm stumped - '93 Ford E350 lurching under load (Motorhome)

    This web page indicates frequencies should be 159 Hz at sea level - and I am pretty sure they decrease approximately 3 psi per 1000 ft above sea level... http://fordfuelinjection.com/index.php?p=27
  4. R

    I'm stumped - '93 Ford E350 lurching under load (Motorhome)

    These were my vacuum readings from a previous post in this thread: I just checked the MAP sensor using the procedure listed in the link below - I know it doesn't list a 7.5L motor, but I think the test is the same: http://troubleshootmyvehicle.com/ford_map_4.9L_5.0L_5.8L/ford_map_sensor_1.php...
  5. R

    I'm stumped - '93 Ford E350 lurching under load (Motorhome)

    Nick, Not sure what you mean here? Dead giveaway to what...?
  6. R

    I'm stumped - '93 Ford E350 lurching under load (Motorhome)

    Sorry to be redundant!
  7. R

    I'm stumped - '93 Ford E350 lurching under load (Motorhome)

    I know that "throwing parts at it" frequently doesn't work that well, but I figure in the long run, I still come out ahead - especially when considering what I would pay a shop or a dealer to fix something. I am also aware of the problems in diagnosing these older OBD1 vehicles...sometimes you...
  8. R

    I'm stumped - '93 Ford E350 lurching under load (Motorhome)

    I do have the old TPS and the leads on it and the harness look good. I want to try and test it by backprobing the leads and moving the throttle, but I'm not exactly sure how to do this (and, it is really a pain to get to this thing on this van motor). So, are we ruling out fuel pressure as the...
  9. R

    I'm stumped - '93 Ford E350 lurching under load (Motorhome)

    I just replaced the TPS and didn't notice any corrosion...
  10. R

    I'm stumped - '93 Ford E350 lurching under load (Motorhome)

    Vacuum at idle in Park = 19" Vacuum at idle in Gear = 17.5" Vacuum at 1500-2000 rpms (no tach so just guessing here) = immediately drops to 13" when I first touch gas pedal then bounces to 20-21"
  11. R

    I'm stumped - '93 Ford E350 lurching under load (Motorhome)

    I have not observed vacuum while driving...has a MAP sensor only. I had previously checked the MAP using the procedure from fordfuelinjecion.com...seemed to perform within specs with a good vacuum supply... I have checked vacuum while idling - within specs as well.
  12. R

    I'm stumped - '93 Ford E350 lurching under load (Motorhome)

    I just checked pressures with return line pinched off - KOEO 34 psi and at idle 65 psi, with a fluttering needle...
  13. R

    I'm stumped - '93 Ford E350 lurching under load (Motorhome)

    Sorry this is long, but I have posted questions related to this issue in other RV forums - let me try to be thorough, but succinct as possible. I have a '93 Cobra Passport on a Ford E350 chassis with a 460 EFI motor, with 62,000 miles. The "first" problem was that the coach would just cut out...
  14. R

    '91 GMC 2500 Vandura - coolant smell and heater core question

    I have a 4.3L full-size van and have just started smelling that sweet coolant odor when the heater is running. I am assuming that the heater core is leaking (I just replaced the water pump, thermostat and radiator). Can someone tell me how to access and remove the heater core? From inside...
  15. R

    Should fuel drip from TBI injectors at idle?

    Thanks for the response. I just went out and checked again to be sure - there is clearly quite a bit of fuel dripping from both injectors on to the throttle plates at idle. Should they be dripping fuel at idle? ryan
  16. R

    Should fuel drip from TBI injectors at idle?

    I have a 1991 GMC full size Vandura Van with 4.3L engine and TBI fuel injection. Been doing some work trying to get it ready for a trip home this month. Van runs well but I have noticed a decline in gas mileage over the past year. Replaced the plugs, wires, cap, rotor, air filter, fuel...
  17. R

    '91 3/4 ton GMC 2500 Vandura Van - shock absorber recommendations?

    I need to replace my worn out shocks. Last time I did this I used Monroes, but I haven't been real happy with them - always have been bouncy and now they're just worn out. The options (KYB, Gabriel at Autozone, Monroes again, AC Delco, etc.) seem endless! I don't want to spend too much, but I...
  18. R

    2001 Neon - Alternator charging problem

    Got it - and thanks for the help. Whoever installed the starter just forgot to connect the fusible link that leads from the starter to the alternator. Took a few minutes to find it but once I got it hooked it up, everything is fine. ryan
  19. R

    2001 Neon - Alternator charging problem

    Thank you for the replies. The starter was changed - by someone else - before I got involved in helping this guy. I am going to start there I think. I have checked the fuses, but I will double check. How do I check fusible links? Voltmeter? Can someone describe a procedure here? Thanks...
  20. R

    2001 Neon - Alternator charging problem

    I did NOT have 12 volts at the big wire - but I was told I shouldn't have voltage. I was told that the PCM had the voltage regulator in it and sends a trickle charge to the alternator as needed. Again, I'm confused. ryan