Search results

  1. G

    Ford Windstar won’t crank.

    Help please! I’ve got a 1999 Ford Windstar van that won’t crank. It’s a 3.8l with 167k on it. I’ve thrown parts at it and still a no crank situation. I’ve replaced the starter and put a fresh battery in it. The electrical system is working. The dash indicator lights work but when I turn the key...
  2. G

    Vehicle shakes and stutters

    I own a 2014 Buick Encore with 53000 miles on it and randomly it will loss power, shakes and stutters when traveling at highway speeds. The dealer did a diagnostic test and said the turbo was bad. We had them install a new turbo and the same problem occurred after the new turbo was installed ...
  3. G

    Parasitic battery drain

    Ford F150 XL striped model a/c only - 7700 series CNG 2002 84k 5.4L Thanks in advance for reading and offering suggestions. I just bought this vehicle and can't figure out the problem. My vehicle has a parasitic battery drain. After the vehicle sits for anywhere from 1 to 3 days I need to...
  4. G

    3.1l engine rotation

    Please fill out the following to ask a question. MAKE: Chevy MODEL: Celebrity YEAR: 1990 MILES: 123000 ENGINE: 3.1 DESCRIBE ISSue.. I'm trying to replace the crank sensor on this vehicle and need to rotate the engine. I attempted to do it as I've done on similar cars like the Lumina Euro...
  5. G

    2004 Cadillac hesitation

    Hello Everyone, I have a question about my 2004 Cadillac CTS 3.6L and wondering if anyone can guide me in the right direction. The car has the check engine light on and hesitates while driving at various speeds. The vehicle has thrown a code po205. The #5 fuel injector was replaced but the...
  6. G

    2001 Ford Windstar Coolant Bypass tube

    Hello, I'm attempting to repair my daughters 2001 Ford Windstar van. It is a 3.8l auto trans with 165k on it. The repair that I'm attempting is the replacement of the coolant bypass tube that is located on top of the intake manifold. I think the tub is pressed into the manifold on the drivers...
  7. G

    Clunking sound from the transmission

    Hello, Once again I need some advice regarding my 1994 Chevy Lumina Euro with 210k on the engine and transmission. I have been keeping this car going by fixing problems as they develope. I now have a new problem that has me wondering if I should attempt to fix it or not fix and keep all of the...
  8. G

    FWD Axle C Clip Not Locking Into Place

    Hello Everyone, I'm working on my 1994 Chevy Lumina Euro auto trans with the 3.1l and 209k on the odometer again! I have the car in my small 1 car garage on safety stands and I'm attempting to install a new drive axle on the drivers side. The process of removing the axle went smooth after...
  9. G

    Caliper Slide bolt Question

    Hello, I have a question that I hope somebody can answer. My question is about the caliper slide bolts on a 1994 Chevy Lumina Euro with a 3.1l engine. The car has 208k on it and I would like to keep it going. About 1.5 years ago I replaced the hub assembly with cheap parts, now I find my self...
  10. G

    1994 Chevy Lumina Euro Low coolant light flashing

    Hello everybody, Once again I'm back on the forum that I hate to love. The hate is because a posting here from me usually means I have a problem that I can't figure out. The love is because I know that with all of the knowledge here my problem will be resolved.... Thanks for your help! I now...
  11. G

    1990 Chevy Celebrity 3.1l running rough

    Hello, I'm glad the forum is up and running again, I sure missed it when it was gone! I'm having a problem with my moms 1990 Chevy Celebrity wagon with a 3. 1l engine and auto trans. I would like to start by saying that the car ran perfect prior to what I did today. I load tested the...
Top