04 Rav4 check eng light flashing runs bad

Wild Bill

Sr. Member
Joined
Oct 31, 2010
Messages
197
Points
18
Please fill out the following to ask a question.

MAKE:Toyota
MODEL:Rav4
YEAR:2004
MILES:155000
ENGINE
:2.4
DESCRIBE ISSUE....Cm eng light flashes rapidly, barely runs, no codes stored. Misfire counts high on #2. Swapped coils on 2&3. Now will not start and scanner shows no communication. Any ideas?
 
Last edited:

Wild Bill

Sr. Member
Joined
Oct 31, 2010
Messages
197
Points
18
Should be ck eng light (autocomplete strikes again)
 

kev2

wrench
Joined
Nov 14, 2006
Messages
4,919
Points
48
Age
119
2004 toyo rav 4 -- sure its a 2.0L?
FYI flashing CEL alerts to a condition that will result in likely cat failure.
Look at plug #2- I am expecting it is wet... advise.

No communication, often the ALDL looses power on pin #16 -a failed fuse.
BUT I suspect there is a wiring issue - - causing the PCM to be unpowered ... is the CEL still getting power/flashing?
I only have a 2.4L wiring so let us know...
KOEO - check fuse box underhood- IGN 15amp....EFI 20 amp...
 

Wild Bill

Sr. Member
Joined
Oct 31, 2010
Messages
197
Points
18
Yes it is still flashing, as soon as the car cuts off the scan tool reconnects.
 

Wild Bill

Sr. Member
Joined
Oct 31, 2010
Messages
197
Points
18
When I first got the car another tech could not get the scan tool to connect, I found the cig lighter fuse blown. Replaced and was able to connect, and stay connected. I had high misfire counts on #2, switched with #3 and that is when I started loosing the signal. When I do grt it to run there is a heavy odor of unburned fuel. I will replace the bad coilpack and hope I can get it to run well enough to diag what I suspect is a bad injector. Thanks, Bill
 

nickb2

Wrench. Diagnostic Tech.
Joined
Nov 22, 2008
Messages
10,767
Points
63
Location
St-Hyacinthe, Quebec, Canada
Just do a fuel leak pressure test. A flashing mil light is always a misfire.

However I highly doubt that two injectors burned at the same time.

Cm eng light flashes rapidly, barely runs, no codes stored. Misfire counts high on #2.
This comment confuses me. Misfire counts high and you have no code. Never seen that before. You should have a P0302 listed on a el cheapo walmart scanner.

Plz repost so we can help you more, because the way I am seeing this thread, a driver in the ECM burned. Plz be more specific.

We will advise further.

Nickb2
 

nickb2

Wrench. Diagnostic Tech.
Joined
Nov 22, 2008
Messages
10,767
Points
63
Location
St-Hyacinthe, Quebec, Canada
If you can get misfire counts, that means the ECM is communicating and your scanner is working. So if swapping whatever component you did, you should still have a P0302 or P0303. If not, suspect a bad ecm or wiring. This is not normal.

I will repeat, if that mil light is flashing, the ecm is telling you something. Cuz without that ecm, there is no way this small truck will run. You are looking at this the wrong way.

I am an aS$hole sometimes in my comments, but you really need to look elsewhere.

Do a compression test, a head check and look at those spark plugs and use NGK platinum for this engine. These things run forever. But the heads are fragile. You can`t tow anything with a 2.4l but if your careful, you will get alot of mileage out of this RAV4.
 
Last edited:

nickb2

Wrench. Diagnostic Tech.
Joined
Nov 22, 2008
Messages
10,767
Points
63
Location
St-Hyacinthe, Quebec, Canada
Also look for vacuum leak on the intake manifold. Buy a noid or LED tester to check injectors., cuz you are going to burn that cat and they cost a fortune. Screenshot (165).png Screenshot (166).png Screenshot (167).png Screenshot (162).png Screenshot (169).png Screenshot (170).png
 

Wild Bill

Sr. Member
Joined
Oct 31, 2010
Messages
197
Points
18
nickb2, It only runs if I rapidly feather the accelerator, for a while it ran and communicated with the scan tool, now it will communicate for a few seconds, long enough to see #3 misfiring after switching #2 and #3. I am using a Snap On MT2500 (brick). I have a spare coil at work that I am putting on next chance I get. I lose com with the scanner after it runs a few seconds and com comes back as soon as the engine dies. I think whatever is happening causes the computer to lose power so any code or pending codes are lost.
 

nickb2

Wrench. Diagnostic Tech.
Joined
Nov 22, 2008
Messages
10,767
Points
63
Location
St-Hyacinthe, Quebec, Canada
Yeah, I worked with the brick for years, they work good but are outdated, but I am slowly staring to suspect a PCM failure. I just use a laptop now. Easier.

Yeah these types of problem's can sometimes take days to find. Not easy.

I see you have skills, GOOD LUCK. I wish all the best.
 

Wild Bill

Sr. Member
Joined
Oct 31, 2010
Messages
197
Points
18
It is fixed, I took the coil and put it on a rav4 we had at work and it did exactly the same thing. Replaced the coil and it runs great, thanks for the help. I thought that I posted a reply earlier, but I don't see it now.
 

Mobile Dan

wrench
Joined
Mar 1, 2002
Messages
3,665
Points
48
Location
Kentucky
Typically, a bad coil only fails to make a spark. I suspect yours had an internal short which caused the ECM to shut down.
 
Top