'05 trailblazer with lots of trouble codes!!!

Joined
May 15, 2008
Messages
2
Likes
0
Points
0
#1
I have a 2005 trailblazer and for the last 2-3 months it's had a rough idle, stalls occasionally at stops, really shaky feeling, surges while driving and sometimes it gets a surge while at a stop. I've had it to 3 different mechanics and no one can figure out what's going on. On my way to the last mechanic, my check engine light came on for the first time since all of this started happening. The car is stock with no add ons and the engine is 4. 2L and it's a 4wd. . . here are all the codes we are getting. . . P0171, P0107, P0463, U1026, U1041, U1064, U1152 I was told that it was coming up the map sensor, but it could also be a leak in the intake manifold gasket??? The mechanic didn't do anything to it yet, because of course he couldn't get it to do anything. On my way home from picking it up, my check engine light came on again! Does anyone have any idea what's going on here?? If so, any advice? I'm getting really frustrated and have already spent a lot of money just to have people tell me they don't know what's going on!!!! :'(
 
Joined
Nov 14, 2006
Messages
4,901
Likes
53
Points
48
Age
119
#2
lots of "u" codes- communications problems between modules..

Was anything done prior to this issue begining?
Accident? new electrical- audio systerm, ?
DO you have a remote starter?

the P codes are p0171 lean bank 1
p0107 Map sensor...low volt sensor...

Both should be checked following the trouble tree it is the U codes that are concernning
 
Joined
May 15, 2008
Messages
2
Likes
0
Points
0
#3
There was an accident but it was minor. It was kinda side swiped but the damage wasn't near the engine or anything. . . mosty the rear door and back to the tail light. Nothing has been done to the car no remote start, no audio systems. . . nothing. The "U" code are what i'm worried about too!