1995 neon

the_graze

Newbie
Joined
Jan 26, 2007
Messages
16
Points
0
I have 2.0 litre neon single ohc when it is cold runs great when warms up it starts to miss fire can hear it backfiring through throttle body i replaced spark plugs did oil change, replaced the coil, air filter, even tried supreme gas nothing sometime if i just keep giving it fuel it will sit there and do nothing but backfire!! Any ideas before it cost me a fortune in trial and error thanks guys. ???
 

Jim Fairbanks

wrench
Joined
Nov 17, 2006
Messages
4,508
Points
38
Location
Portland,Oregon
Have you had the fuel pressure checked?..How about the fuel filter?..Sounds like it could be a vacuum leak..Jim
 

Transman

Receptionist & Complaint Dept.
Joined
Nov 14, 2006
Messages
2,953
Points
0
Location
New Jersey
Website
www.edsofvineland.com
Mileage? Timing belt? These puppies are extremely sensitive to spark plugs, what brand plugs and wires did you use? There are several TSB's just about the spark plugs. You really need to stop throwing parts at this one and try to find the real problem. Get the fuel pressure test performed as Jim suggested and totally look for vacuum leaks at the hoses, look for sucked in or really soft or even brittle hoses. Listen for hissing sounds with the engine running and try to track it down. Transman
 

the_graze

Newbie
Joined
Jan 26, 2007
Messages
16
Points
0
thank you and yes just noticed after changing the EGR valve that there seems to be gas spots on ground so i will follow your advise thank you for replying to my question. let you know how i make out.
 
Top