2000 chevrolet venture 3.4

nievla

Jr. Member
Joined
Nov 24, 2008
Messages
42
Likes
0
Points
0
#1
hi I have a 2000 venture 3.4 and the transmission don`t shift some times ., The fluid look`s good and smells good some times the transmission comes back to normal. the codes I am getting is P0742 and P1811 is there any one could help me with this trans problem?
 

Transman

Receptionist & Complaint Dept.
Joined
Nov 14, 2006
Messages
2,953
Likes
0
Points
0
Location
New Jersey
Website
www.edsofvineland.com
#2
These are bad codes, you didn't say what kind of mileage and service this has had. The 742 is TCC stuck on and the 1811 is shift adepts at max. Do the basics, check for bad grounds and corrosion at connections. Don't forget to check the battery connections. When was the last tune-up? Vacuum lines? Any add-ons, radio, alarm, air filter?
The bad news is the trans probably needs an overhaul, these are internal leakage problems generally. Always the chance of connection issues or alternator problems and a bottle of lubegard "red" couldn't do any more damage and might buy you some time. Post back, Transman
 

nievla

Jr. Member
Joined
Nov 24, 2008
Messages
42
Likes
0
Points
0
#3
sorry the van have 127000 miles . fluid was changed 3 months a go now the fluid looks good and don`t smell burnt I am thinking to replace the tcc solenoid any recommendations?
 

Transman

Receptionist & Complaint Dept.
Joined
Nov 14, 2006
Messages
2,953
Likes
0
Points
0
Location
New Jersey
Website
www.edsofvineland.com
#4
I think it's too late for a TCC solenoid and that is only a small part of the problem, the 1811 is the bad one. The trans computer cannot add any more to stop the slippage between shifts. Time for a good overhaul, Transman