2004 Buick rendezvous wipers do not work

The old man

Hero Member
Joined
Aug 3, 2007
Messages
829
Likes
0
Points
16
#16
Here is a better diagram of the system before the fuses that concern the problem. Had to go over the yellow lines. They don't show up very well on the diagram. You said that your turn signal were working. Is that correct? May be a bad wire or a bad fuse socket in the fuse block. Needs to test voltage at areas above the fuses in the diagram.
 

Attachments

kev2

wrench
Joined
Nov 14, 2006
Messages
4,885
Likes
53
Points
48
Age
118
#17
try swapping -for test- relay #20 and #27..... diagram of fuse box attached
 

Attachments

Joined
Mar 29, 2007
Messages
52
Likes
0
Points
0
Location
North Vernon IN
Website
scottyspot.tk
#18
kev2 said:
try swapping -for test- relay #20 and #27..... diagram of fuse box attached
That did it, and now the aftermarket radio that is in the unit stays on for the 10 second interval. Looks like I am going to buy a relay!

Thanks everyone for your help! Maybe I should stick around a lot more, and if people have problems with a Cummins engine I can help out. I have full QSOL access (and loads of other access) and did engine support for over 5 years on those. I still work for the company, but in software implementation.
 

The old man

Hero Member
Joined
Aug 3, 2007
Messages
829
Likes
0
Points
16
#19
I told you that we had really good people on this site that could help you with your problem. It helps to have someone like you on the other side to understand what the people on this site are trying to tell you. Good calls to all to pinpointing the problem.
 

kev2

wrench
Joined
Nov 14, 2006
Messages
4,885
Likes
53
Points
48
Age
118
#20
aftermarket radio!! a symptom or cause ?

- let us know how things workout
 
Joined
Aug 28, 2007
Messages
4,704
Likes
19
Points
38
#22
Did this relay say, "Made in China" on it? This is the latest problem bestowed upon us. These are strictly throw away types, no longer can a guy clean the contacts.
 

Gus

wrench
Joined
Dec 8, 2006
Messages
2,421
Likes
0
Points
36
#23
Nick, 10 year old relay that carries a lot of current? Want them to last forever? :ROFL
 
Joined
Mar 12, 2019
Messages
1
Likes
0
Points
1
#25
try swapping -for test- relay #20 and #27..... diagram of fuse box attached
I actually had this same problem. Replaced the motor and got nothing. I tried swapping relay 20 and 27 and the wipers budged. They only go down. Same thing when i replaced the relay, they budged down then nothing else. It makes a slight noise once and again as if the wipers are on delay, but they dont move after that initial budge down. I had hope. I dont know what else it could be.