2005 chrysler pacifica cooling fans stay on

Joined
Apr 24, 2009
Messages
5
Likes
0
Points
0
#1
my pacifica started running the cooling fans about two minutes after I shut the vehicle off. i would not think it is the relay because if it was stuck the fans would be on right away when i shut it off, any help would be appreciated. i heard there was a factory problem with this that might require getting the PCM flashed. has anyone heard of that.
 
Joined
Nov 14, 2006
Messages
4,919
Likes
53
Points
48
Age
119
#2
I will look for info If you could help us by answering.......

are you origional owner? this is new development just started happening?

operating vehicle temp is normal shut off then in @2minutes the cooling fans come on -correct?
how long will they stay on?

Is the check eng light on?
Are there ANY modifications or added devices esp. electrical?
 
Joined
Apr 24, 2009
Messages
5
Likes
0
Points
0
#3
not the original owner, no mods, just started happening, temp normal, fan is on when vehicle running cold and no a/c or defrost on then shut off and after 1 to 2 mins comes on and would stay on, today I noticed when i went and hooked the battery back up it came back on and runs continuous however a couple times it cut out down to half speed and then started back up almopst as if it lost power for a few seconds. i am going to pull the relay, any idea how to test it to make sure it is working correctly. . . . . . . . . forgot the engine code po480 came on also
 
Joined
Nov 14, 2006
Messages
4,919
Likes
53
Points
48
Age
119
#4
P0480
Cooling Fan 1 Control Circuit
An open or shorted condition detected in the low speed radiator fan relay control circuit.


you WILL need a wiring dia, test light and a DVOM.....
taking a swag.. LIKELY PCM to relay shorted to ground ....





p
 
Joined
Apr 24, 2009
Messages
5
Likes
0
Points
0
#5
have you ever heard of the PCM causing the grounding issue which causes the fans to stay on. car only has 60k on it, visual inspection shows no problems,
 
Joined
Nov 14, 2006
Messages
4,919
Likes
53
Points
48
Age
119
#6
when fans commanded the PCM supplies 12v (brn/vio-wire) feed from pcm to the relay which is always grounded (blk/dkgrn) wire.
YES the PCM "drivers" can fail*.....
YOU should check the circuits pcm to relay, I would ck fans for a hi amp load Or swap relay BUT the 2min wait time has me thinking problem is mentioned wire from pcm to relay .....


only thing I want to confirm is -no remote starter or alarm?

*PCM I think repeat think are warranty 8yrs
 
Joined
Apr 24, 2009
Messages
5
Likes
0
Points
0
#7
no no remote start or alarm, now i was playing with it again and pulled the relay, when i hook the relay back up, the fans start immediately, key in off position just hooking relay back up with power
 
Joined
Apr 24, 2009
Messages
5
Likes
0
Points
0
#9
latest news, i put relay back in vehicle with battery hooked up. everything is working fine again. checked relay and relay seemed to be working fine so i put it back in. so we will see if this acts up again. possibly corrosion in relay that broke free from me playing with it, or something else that his its ugly head fro now. appreciate the help and i will keep you informed.