2005 Toyota Camry 4Cycl - No Accerlation

slin

Newbie
Joined
Sep 26, 2007
Messages
2
Points
0
Hello,

I have an 05 Toyota Camry with 68K miles on it. First it started cutting off when I accelerated. So I took it to the Toyota dealer and they did a diagnostic on it and it came back with codes P2101 and P2111...says the throttle body was bad. I was able to continue to drive it for about 2 days then it completely shut off and would not come back on until it cooled off. I got the part and thought I had it fixed, but now it won't even accerlate when I press the gas pedal. Can you help me with what to do next? Was this a recall item?
 

csaxon

Full Member
Joined
Nov 20, 2006
Messages
139
Points
0
Did the new throttle body come with a new hose part#22231-28030? Toyota redesigned the hose to the throttle body that caused your codes and symptoms. It was a free fix up to 50,000 miles.

Item Number MSRP Price HOSE, THROTTLE BODY
2223128030 $9.46 $6.54
 

Transman

Receptionist & Complaint Dept.
Joined
Nov 14, 2006
Messages
2,953
Points
0
Location
New Jersey
Website
www.edsofvineland.com
That one should be "Fly by Wire" and if it is then there is a specific procedure to "re-learn" the computer to throttle body. These vehicles are so sensitive that cleaning the throttle body even with the key off can force this re-learn process. If you have a throttle cable that connects the accelerator pedal to the throttle body then this is not your problem. Post back, Transman
 

2POINTautO

Hero Member
Joined
Apr 27, 2007
Messages
379
Points
0
If you have the ETCS with the APPS then you still have a throttle cable and you have a computer driven (additional) throttle plate, this setup will not allow accelleration when it goes bad, I have only delt with it one time and it needed a complete large throttle body assy with escentially two throttle bodies in it. I do not recognise the codes they gave you. Is your problem intermittent, mine was. You said you got a part, what part did you buy that did not fix it and was it new or not.
 

slin

Newbie
Joined
Sep 26, 2007
Messages
2
Points
0
I really appreciate your responses!
The problem is not intermenant, but persistant. It started as intermenant. I was doing some research and found a TSB for one of the codes (P2111) and the Toyota dearler said that the other code (P2102) was in relation as well.....Bad throttle body. The TSB was# 02305 from 5/17/05.
Unfortunately, I could not afford to purchase a brand new throttle body ($700+) from Toyota. I found a used part from a salvage yard. I did not purchase any hoses. Could that be the reason it's not working....the hose?
I also replaced the sensor on the pedal, hoping that was the problem. But that didn't work either....still no accerlation...no "rev" when the gas pedal is depressed. Could it be the computer?
 

csaxon

Full Member
Joined
Nov 20, 2006
Messages
139
Points
0
Toyota only "modified" the throttle body hose I mentioned above to solve the errant DTC in your model year. The throttle body was not changed.

You can remove the air intake hose from the throttle body and observe the throttle plate movement as someone moves the accelerator pedal. If it's not moving much then I'd start by replacing the hose I mentioned above, especially since you've already replaced the throttle body itself.
 
Top