2007 Chevy Impala head gaskets

Drew99GT

Newbie
Joined
Nov 24, 2007
Messages
6
Points
0
We have an 07 Impala with the 3. 5L V-6, 64,000 miles. Apparently the head gaskets are going out on these engines from 06-08; ours was losing a ton of antifreeze and the dealer replaced the head gaskets, crossover pipe gaskets, and the water pump under warranty at 61,000 miles.

I went to top off the cooling system yesterday and try and bleed it by running the engine with the cap off and heater on. Started the engine when it was stone cold and to my shock, there was tons of bubbling and fizzing like you'd get with a bad combustion to cooling system head/gasket leak. And when I rev the engine, the level rises instead of falls like what normally occurs. There are no other symptoms - no overheating, hasn't hardly lost any antifreeze since the repair, it runs great.

Have you guys ever seen symptoms like this that wasn't a head gasket problem? Could it just be the design of the system and placement of the waterpump compared to the filler neck for the cooling system (the cap is not located on the radiator), and I'm seeing churning coolant from the water pump?

Thanks guys for any info and help.
 

Wild Bill

Sr. Member
Joined
Oct 31, 2010
Messages
197
Points
18
Need to check it with a block tester that detects exhaust gasses in the cooling system.
 

Gus

wrench
Joined
Dec 8, 2006
Messages
2,421
Points
36
Why are you topping off coolant on a job done 3K ago? Bring it back to the dealership and let them do it....should be under warranty.....I don't believe the procedure for venting the system is with the cap off the reservoir.......I think the cap has to be on, and the engine revved at a certain rpm for a period of time......then shut off, and the cap slowly removed and then topped off....then repeated........knew about the crossover gaskets, didn't know about the head gaskets......I guess if the coolant got low enough, could cause head/head gasket problem....
 
Top