2012 mazda 6 – P0172:00-ac and P0172:00-af.

nickb2

Wrench. Diagnostic Tech.
Joined
Nov 22, 2008
Messages
13,010
Points
83
Location
St-Hyacinthe, Quebec, Canada
so essentially, you r stuck with my sorry arse, telling you the same thing over again.

You state, you have forscan.
 

nickb2

Wrench. Diagnostic Tech.
Joined
Nov 22, 2008
Messages
13,010
Points
83
Location
St-Hyacinthe, Quebec, Canada
Inside of the throttle body, APP senor reside. it has a double back.

I suck at english, but i dont care. The engineers gave a redundancy to this, hence the live dsata I talk about.
 

tull_rules

Newbie
Joined
Dec 26, 2022
Messages
11
Points
1
To be clear, stalling and limp mode (traction ctrl/abs/cel and another indicator would show on dash and I would lose power and was not able to go above maybe 30mph) - those 2 issues have been resolved. I will suggest APP to the mechanic I will be seeing first week of the new year.
I am all ears - I am in no way dismissing anything you gents are suggesting - Like I said all this has been a learning experience for me. As for mode 6/forscan - i will have a go at it when I am home - Thank you all
 

nickb2

Wrench. Diagnostic Tech.
Joined
Nov 22, 2008
Messages
13,010
Points
83
Location
St-Hyacinthe, Quebec, Canada
Ok, sorry I had to leave thread, family and friends etc.

My neighbour denis came by, gave me a broken compressor. I will try to post that also.

anyway, what is a APP sensor. from my understanding, the accelerator pedal position sensor uses a double feedback, and if you dont have access to real live data, you wont see the feedback on that one.

 

nickb2

Wrench. Diagnostic Tech.
Joined
Nov 22, 2008
Messages
13,010
Points
83
Location
St-Hyacinthe, Quebec, Canada
If I read correctly. the dongle you have is a elm 327 chip, this chip is by now no longer supported for some mazda models.

I linked you a clone that I have used. It is pretty, good, but if you want, maybe invest a bone or 2 more and go somewhat higher end.

 

tull_rules

Newbie
Joined
Dec 26, 2022
Messages
11
Points
1
Gentlemen,
For your information and so that maybe this can help someone else with a similar situation,
This is what finally fixed all my issues. The mechanic I reached out to prior to new year's diagnosed a corroded ground on the driver side rail.
According to him it was shared by other elements and therefore caused the various issues. After they corrected that, my car no longer had a blinking "D" , no hesitation/jerky accel, no limp mode etc. However, the rich code remained! i went back to him and after changing my MAF (this is like the 5th MAF) it appears that this one is a winner! No more rich code! my car is now 100% and i am a very happy and relieved individual.
Thank you all for taking time to reply to me before - i appreciated your help
 
Top