90 S10 Stumbles

7s10s

Newbie
Joined
Apr 5, 2008
Messages
3
Points
0
I have a 90 S10 2. 5 and 5 sp. 175K, engine stumbles at cruise speeds with light throttle or when backing off throttle. No codes and have changed all sensors twice, ecm, injector, fuel filter, fuel pressure regulator, fuel pump, plugs and wires, dist cap and rotor, pickup coil, no help. Scanner shows everything working right. Checked timing. Truck will accelerate and run fine, passes emission test every year. It just bucks and kicks back at light or no throttle about 45 to 55 mph. When it starts stumbling I can step on the throttle and it stops and accelerates fine????? Thanks for any HELP!!
 

crunch

wrench
Joined
Nov 14, 2006
Messages
2,079
Points
36
Good fuel pressure?
Did you ground A & B pins together to set base timimg?
Tps sensor good?
At what rpm does it do it?
 

7s10s

Newbie
Joined
Apr 5, 2008
Messages
3
Points
0
I have not checked the fuel pressure (no test gauge) but I installed a 20 gal tank to replace the 13 and used a new fuel pump. Stumble was there before and after new pump installation, and the truck will accelerate fine when pushing down the gas peddle. I did ground A & B during timing check, and disconnected the IAC as the book said. I did have the distributor out when I replaced a failed pickup coil. TPS has been replaced twice but not since I replaced the ECM. My son has my scanner right now and I'm not sure of the RPM when the stumble happens but it happens in 4th about 35 to 45 MPH and in 5th around 45 to 55 MPH. I have not noticed it in the first 3 gears but I my usually accelerating then. Doesn't seem to happen with the peddle past half throttle?? Thanks.
 

Roy

wrench
Joined
Nov 13, 2006
Messages
1,047
Points
0
Disconnect & plug the vacuum hose to the EGR valve & test drive.
 

7s10s

Newbie
Joined
Apr 5, 2008
Messages
3
Points
0
:) OK, unplugged EGR and plugged vacuum hose. Engine runs OK, no stumble but idle is very high and hunts. Engine missed a few time on acceleration? I believe ERG solenoid controlls EGR valve, so I will try and find the check for solenoid? and check the EGR valve, and look into high idle, maybe idle screw is set wrong with EGR problem. Will have to do an idle check once EGR problem is fixed? Any other ideas would be appreciated. Thanks.
 
Top