"98 Achieva will only run for one second

Joined
Mar 1, 2002
Messages
3,611
Likes
61
Points
48
Location
Kentucky
#1
Acts like a Passlock issue, but "security" light does not flash after it dies...it stays on steady.

Had a crank sensor code....customer's boyfriend found that torn belt had cut through the wires of the sensor by the crank pulley. He replaced the sensor, now code is gone, but still only runs for one second.

Customer says it did the "start and die" even before the sensor was changed....and she never had a starting problem previously.

This car has the 3.1 engine, there is a crank sensor buy the pulley and another in the block.

My scanner shows RPM rising, then falling during the start and die. I have no access to body codes.

This car has a Passlock system, so there is no chip required in the key.

There is a fuse labled "alarm" which tests OK.

I invite any tips, info, or suggestions.

Dan
 

Gus

wrench
Joined
Dec 8, 2006
Messages
2,421
Likes
0
Points
36
#2
Are there any Pcm, BCM, or IPC codes set?

Spray carb cleaner into the intake...... if it runs and continues to run as long as you spray, then you either have a fuel presure or fuel delivery problem...a Security problem will shut down the injectors....
 
Joined
Mar 1, 2002
Messages
3,611
Likes
61
Points
48
Location
Kentucky
#3
so..if the security system is shutting down the injectors, I guess that could be considered a fuel delivery problem.

What about the Security light...if the system is keeping the car from starting, would it be flashing or be on steady? This is what happens...when key is off, light is off.....turn key on, light comes on steady....Crank, engine starts immediately, let key spring back to "on", engine runs 1 second then stalls,light is on steady. If I leave the key on for 10 to 15 min., the light stays on steady. (had a charger on to keep the voltage around 12v)
 

Gus

wrench
Joined
Dec 8, 2006
Messages
2,421
Likes
0
Points
36
#4
Certainly sounds like a Passlock problem......check for those codes....
 

Transman

Receptionist & Complaint Dept.
Joined
Nov 14, 2006
Messages
2,953
Likes
0
Points
0
Location
New Jersey
Website
www.edsofvineland.com
#5
I could be off here but my recollection of this passlock system is that once it starts the passlock is ineffective ( it still checks but can do nothing after the car is running). Especially since the security light is not on or blinking. I would recommend a fuel pressure test to see if the fuel pump is working, filter etc. as a starting point. Post back, Transman
 

Gus

wrench
Joined
Dec 8, 2006
Messages
2,421
Likes
0
Points
36
#6
Transman, when you turn the key on, the pump is building up pressure for two seconds...when the car cranks, the injectors fire and the engine starts.....if the Passlock module doesn't send the correct R-code to the IPC(or in somecases the BCM), then a fuel enable signal is not sent to the PCM, and the PCM shuts down the injectors....