99 Buick Century 3.1 engine rpms unstable surging

keith

Sr. Member
Joined
Dec 21, 2007
Messages
176
Likes
0
Points
16
#1
The car was brought to me like this. When it gets warm the RPM's surges (many to 2000) and falls about 4 times then the car dies. Seems to do this only when the car is warmed up but not sure. Had a code for running lean. The air filter was plugged (changed), changed the fuel filter, checked the IAC, egr, map, and fuel pressure, also I could not find a vacuum leak and I replaced the PCV. This one has be pretty stumped, the car is pretty consistance with the problem so it should be easy enought to fix. It also is not missing. Aso when it do this it smell like it is running rich like the exhaust is smelly. Any ideas??

99,xxx miles
 
Joined
Aug 28, 2007
Messages
4,805
Likes
26
Points
48
#3
What really screws up idle air control is leaking intake valves, shoves a lot or even some combustion air back into the intake manifold. Would to a compression test first and get that out of the way.
 

keith

Sr. Member
Joined
Dec 21, 2007
Messages
176
Likes
0
Points
16
#4
on these GMs the MAF is in the pipe by the air filter so it does not really get dirty and I tried another one off a car also in the shop same thing,

I will check compression.

It is running lean, only thing I can think is a intake leak?? But cannot find one or hear it. On time I saw an intake leak that was sucking air from the crank case and pulling a vacuum on the crank case, I pulled PVC and did not feel vacuum.

Anyone see a bad intake on these causing this problem?? I see bad intakes on these 3.1 and 3.4 all the time leak oil and coolant but never this

Any ideas??
 

jay

Hero Member
Joined
Nov 14, 2006
Messages
445
Likes
0
Points
16
Location
NC
#5
Check to make sure the fresh air pipe is securely in the grommet on the rear valve cover. It can easily get disturbed if the air-intake hose assembly has been removed from the t-body.