99 honda passport, EVAP problem

A

arnold

Guest
#1
i am working on a 99 passport 3.2, w vin. code, its got almost 100k miles , check eng light is on, code po440 i suspect the canister assy, next to the fuel tank , all the hoses and stuff look ok, there also is power to the solinoid sw, but the valve is rusty, and when it powers up there is no switching noise, i was looking for a clicking sound, there is none, any info, or feedback would be greatly appricated, thanks ???
 

Paul

I'm The Decider
Joined
Nov 14, 2006
Messages
1,576
Likes
0
Points
36
Location
Usa
#2
Any chance the vehicle was refueled with the engine running or the gas cap left off?Make sure the gas cap is tight.You mentioned rust,check to make sure the lip if the fill pipe is free of rust.Thats the first step when dealing with this code.
 

jay

Hero Member
Joined
Nov 14, 2006
Messages
445
Likes
0
Points
16
Location
NC
#3
rub a smear of vasoline or syn grease on the filler cap O ring and re-install cap and clear MIL. Drive if and if MIL does not come back on, you have proven that cap is source of problem. Have also seen dents in filler neck that also prevented cap from getting good seal. What was MIL code? Was it gross evap leak?
 
A

arnold

Guest
#4
jay said:
rub a smear of vasoline or syn grease on the filler cap O ring and re-install cap and clear MIL. Drive if and if MIL does not come back on, you have proven that cap is source of problem. Have also seen dents in filler neck that also prevented cap from getting good seal. What was MIL code? Was it gross evap leak? not gross leak, just emmision control sys problem, is the description. also i did not see rust on the filler, i will look again, also i believe the cap was already 5replaced, when the light 1st came on, codes where cleared, light shortly reappeared i will check it all out again monday morn, thanks
 
A

arnold

Guest
#5
the description was not gross leak, it was emmision control problem, i believe the cap has been replaced, and codes cleared, but i will check again monday morn, thanks for the help arnold
 
A

arnold

Guest
#6
i checked with the car owner, the cap is new, and codes where cleared, the top of filler neck is a bit rough, so i cleaned it up and applied the vasalene to make a good seal, cleared the codes out, i ran it for maybe a hour, let it cool down for a couple hours, then drove for almost an hour, still no check eng light, how many times will it have to cycle to be sure? thanks for the help arnold