99 mitsbishi gilant 2.4 198000

coupons

Jr. Member
Joined
Dec 17, 2011
Messages
45
Likes
0
Points
0
#1
the car will not start just cranks and cranks changed plugs and battery still will not startany possiable remendy plz need help
 
Joined
Nov 14, 2006
Messages
1,395
Likes
1
Points
38
Age
119
#2
Does it crank a little bit faster than it used to ? As in it lost compression due to a timing belt having broken. Lets start with the basic, fuel, spark, air. Is there gas in the tank ? Is the fuel pump running ? Is it delivering proper PSI and volume. Are the injectors firing. Does it have spark ? Are the wires good ? Are the plugs wet and gasoline fouled ? There are so many questions, compression test would be a first, don't want to put money in to a possibly dead engine. After that I would check all the fuses. Next check spark. After that I would start running test on the fuel delivery system. You can probably rent a fuel pressure tester at the local auto parts house.

Ford_Dude
 

coupons

Jr. Member
Joined
Dec 17, 2011
Messages
45
Likes
0
Points
0
#3
to the first q. no it does not crank faster it seems to really slow cranking. yes i have spark. compression seems week. i took the front plastic insp cvr off the belt looks good but i know that dont mean much. as i am cranking i can smell gas
 

JimD10796

Full Member
Joined
Jun 20, 2011
Messages
70
Likes
1
Points
8
#4
CEL light on? and did you test for spark at 1 plug or all of them. Maybe one of the coils went out, seen that before, dang thing won't run. Next i'd bring it up to TDC and check the cam marks, and finally a compression test if all is good there.
 

coupons

Jr. Member
Joined
Dec 17, 2011
Messages
45
Likes
0
Points
0
#5
no cel is not on and yes check all plugs for spark had spark on all it just seems real sluggage trying to start the compression seems to be real low but thats without checking with a gauge. just sticking a stick in the hole barely pushit out . im not to familiar with the car it belongs to my son im just trying things i would checkany help is appreciated. ty
 

billr

wrench
Staff member
Joined
Mar 12, 2007
Messages
6,448
Likes
80
Points
48
#7
How long does it run for, does it stop as soon as the key is moved out off the "start" position?
 

billr

wrench
Staff member
Joined
Mar 12, 2007
Messages
6,448
Likes
80
Points
48
#9
Oh, so it's not really starting now, it just fired briefly that one time. That "sluggish cranking" makes me wonder about the battery, has it been load-tested? Nothing about the engine starting and operation is optimal when battery voltage is low...
 

coupons

Jr. Member
Joined
Dec 17, 2011
Messages
45
Likes
0
Points
0
#10
yes we have a battery charger on the car to pick up the cranking and still wont start it started one time for a couple of secs. after that just cranks begining too wonder if crank sensor is bad. im getting yellow spark on the plugs is it supossed to be blue or yellow ok too im getting fuel you can smell it while we r cranking.
 

billr

wrench
Staff member
Joined
Mar 12, 2007
Messages
6,448
Likes
80
Points
48
#11
Having a battery-charger on it means nothing. You could measure voltage at the battery while cranking (charger off), that would help... if you don't want to take it out and have it load-tested. It reminds me of when I was a kid and did all kinds of fancy testing on a battery and convinced the customer (and myself) that the battery was bad, then removed the battery and one end of its case fell off! Could have saved a lot of time if I had just removed it first.
 

coupons

Jr. Member
Joined
Dec 17, 2011
Messages
45
Likes
0
Points
0
#12
ok i under stand where u r coming from. but if i put the charger on it and it cranks faster shouldn't it start ? i will change out the battery and c if it helps ty again.
 

billr

wrench
Staff member
Joined
Mar 12, 2007
Messages
6,448
Likes
80
Points
48
#13
Whoa! I am not saying to change out the battery (just yet). I am suggesting you get it load tested, or check voltage while it is cranking (a load test). If you put a charger on it and it cranks faster, that just means the voltage is better than before, not that it is proper/adequate. And, if you are using the charger to "boost" while cranking, it may be putting a lot of AC ripple on the system, that may be upsetting the car's electronics.
 

nickb2

Wrench. Diagnostic Tech.
Joined
Nov 22, 2008
Messages
9,652
Likes
176
Points
63
Location
St-Hyacinthe, Quebec, Canada
#14
If your getting spark, the crank sensor should be ok. I am wondering about secondary ignition circuit. You say you changed out the spark plugs. Can you get the KV output to plugs? Maybe you have a coil or two that is weak. You want at least 20000volts at coils. When compression is low, check for gas in cyl, valve leaks, bad rings. Try changine the oil, pulling the spark plugs and cleaning them with brake cleaner and add new oil. You said you smelled gas. I think it may have flooded and brought compression down.

If and when you do what I said, then take compression with fuel system disabled and add a few drops of oil in the cylenders, if the comp goes up, you rings are shot. This is a high mileage car.

Also, try seeing if the engine will take with the brake cleaner to cylinders via a vacuum line with fuel system disabled. Does it start? If so, your ignition system should be ok and you have a fuel problem such as a fuel filter clogging or such.

Hope to see what your findings will be.

Nickb,
 

coupons

Jr. Member
Joined
Dec 17, 2011
Messages
45
Likes
0
Points
0
#15
i have changed the battery i am getting gd cranking now but will still not start. i have used a little bit of starting fluid through the air intake and it still wont start so it makes me think maybe a weak fuel pump possiable not for just wondering i am getting yellow spark through the spark plugs is it post to be blue or does it matter. ty for your replys evrything is welcome.