99 Navigator, 4.9l, 2x4, 140k.

C

Cliff

Guest
#1
I just changed the individual coils and spark plugs on my son's Navigator because it seemed to be running rough. Though the vehicle is running fine, I'm getting a P0430 - Catalytic Efficiency is running below threshhold Bank 2. I smell the faint odor of gas. I'm not getting any misfire codes, just the P0430.
Exhaust system doesn't seem to have any leaks. Do I have a misfire condition or should I be checking something else. Any help would be appreciated.

BTW - I've used this forum for some years now. You've all been great.
 

Paul

I'm The Decider
Joined
Nov 14, 2006
Messages
1,576
Likes
0
Points
36
Location
Usa
#2
To diagnose this code one needs a scan tool capable of reading various sensors etc.Start by checking the wiring to all the O2 sensors and the fuel psi.Engine off psi should be 35-45 psi and the engine running psi should be 28-45 psi.When was the last time the air and fuel filters were replaced?What brand of spark plugs did you install?

Also,the engine should be the 5.4L,either Vin code A or L.The eight digit of the Vin will tell you which.
 

Transman

Receptionist & Complaint Dept.
Joined
Nov 14, 2006
Messages
2,953
Likes
0
Points
0
Location
New Jersey
Website
www.edsofvineland.com
#3
How many miles? be suspicious of the front o2 as the culprit on a cat eff. code. A scanner graphing the o2's helps bunches in diagnosing these type problems. Does it code left bank or right bank? Another big thing especially on Fords are vacuum lines, mostly at the pcv valve and the other end. Post back with info, Transman