allison t codes P0700,U2104,U2105

Joined
Jul 14, 2007
Messages
2
Likes
0
Points
0
#1
I have a 2003 chevrolet 2500 HD 4wd with the 6.6 diesel and 5 spd allison tranny. I have noticed it started to shift funny(hard shifts and shifting into the next gear at higher rpms under low load/low throttle) I got three trouble codes, P0700,U2104,U2105, I am fairly skilled at wrenching and currently the vehicle is out of warrenty. Do these codes point to a bad sensor or solenoid? I would like to do the work myself as I am aware of a problem with GM transfer case's oil pump clip rubbing though the case( currently ok) and this could be repaired at the same time
 

Transman

Receptionist & Complaint Dept.
Joined
Nov 14, 2006
Messages
2,953
Likes
0
Points
0
Location
New Jersey
Website
www.edsofvineland.com
#2
Although I am against throwing parts at a problem, this is the exception. Throw a range mode switch at this one fast! Neutral switch to us old timers. These are very common and full of problems. Go right to the dealer for it, accept no substitutions. Clear the codes and see what (if anything) comes back, I suspect you will solve it with the single part. Good Luck and post back, Transman
 

Transman

Receptionist & Complaint Dept.
Joined
Nov 14, 2006
Messages
2,953
Likes
0
Points
0
Location
New Jersey
Website
www.edsofvineland.com
#4
Just an add to tell you that it truly can be that simple, most people look for something to be difficult and costly even though they hope it is something simple, but that never happens to us, right? All the data to and from the computer to the trans goes through this stupid switch instead of just using it to tell the range you have selected. I have had almost every symptom from this switch being bad from stall outs, rough running to no gears or slipping shifts. Post back, Transman
 
Joined
Oct 17, 2009
Messages
3
Likes
0
Points
0
#5
2000 silverado 2500 series 4x4,trans question

guys,i have a 2000 silverado 2500 series 4x4. 4l80 trans.will not shift out of low,neither will speedometer work.problem started when selonoid on starter stuck.selonoid coil wires grounded against case of selonoid,after repairs to starter were made.scanner says open/shorted circuits to all selonoids,tcc,and pwm.also says no communcation with instriment cluster.trans has 12v to main connector,all grounds are good up to pcm selonoids will kick in trans when grounded from pins at pcm,have changed speed sensors.did problem with starter blow ground circuits in pcm? pro-3 in question
 

Transman

Receptionist & Complaint Dept.
Joined
Nov 14, 2006
Messages
2,953
Likes
0
Points
0
Location
New Jersey
Website
www.edsofvineland.com
#6
pro-3, Start a new post and you will get more responses plus it's the right thing to do. In the meantime, check your wiring for shorts and opens. Possibly a fuse link smokes when the starter did. The point is "No Power, No workee" to this trans. Transman