TOYOTA PASEO 98 1.5 66kw very bad cold start

nr_paseo

Newbie
Joined
Feb 17, 2021
Messages
3
Points
1
Make
Toyota
Model
Paseo
Year
98
Miles
?
Engine
66kw 1.5
Hello, my Toyota has trouble starting when the outside temperature is above 5 degrees. starts about 10-15 times. When heated, the car will start for the first time. the ECT sensor is replaced by no change. the car only has OBD1 and reports error 22. can you advise where the problem may be?

My english is bad - Google translator ;)
 

Attachments

nickb2

Wrench. Diagnostic Tech.
Joined
Nov 22, 2008
Messages
11,863
Points
63
Location
St-Hyacinthe, Quebec, Canada
Hmmm, are you sure that your car is OBD1 cuz toyota, at least in canada, was obd2 by 1996. so if your car is from new zealand or something which may have switched to obd2 later than 1996, I am afraid the advice I MAY give MAY be faulty.

So I am going to go with a 1995 since it is obd1.

A fault 22 is the coolant sensor circuit, which makes sense. You say you changed the sensor, so now, look at wiring, pins etc. If all good, ecm. Pretty straight forward back then.
 

nr_paseo

Newbie
Joined
Feb 17, 2021
Messages
3
Points
1
Hmmm, are you sure that your car is OBD1 cuz toyota, at least in canada, was obd2 by 1996. so if your car is from new zealand or something which may have switched to obd2 later than 1996, I am afraid the advice I MAY give MAY be faulty.

So I am going to go with a 1995 since it is obd1.

A fault 22 is the coolant sensor circuit, which makes sense. You say you changed the sensor, so now, look at wiring, pins etc. If all good, ecm. Pretty straight forward back then.
when I disconnect the sensor, the radiator fan turns on

Ikona Overené komunitou
 

Mobile Dan

wrench
Joined
Mar 1, 2002
Messages
3,740
Points
48
Location
Kentucky
Perhaps that car has more than one "engine temperature sensor" and you replaced the wrong sensor? Possible sensor needs would be for fuel injection, temperature gauge, radiator fan.
 

billr

wrench
Staff member
Joined
Mar 12, 2007
Messages
7,048
Points
63
Rockauto listings do show two different sensors for that engine; both a 1-wire and 2-wire. I'm still wondering why this '98 does not have OBD2. What market was the car built for?
 

Mobile Dan

wrench
Joined
Mar 1, 2002
Messages
3,740
Points
48
Location
Kentucky
Looked up parts for 1998 US car with 1.5L engine and found this...for fuel injection sensor three wires, for temperature gauge sensor one wire, for radiator fan sensor one wire.
 

nickb2

Wrench. Diagnostic Tech.
Joined
Nov 22, 2008
Messages
11,863
Points
63
Location
St-Hyacinthe, Quebec, Canada
I NEED to know what region of the planet this was sold in.

After that MAYBE I can help. But I wont do a wild goose chase if we are looking at a foreign market car which will not align with my data base.
 
Top