Won't start 2005 Pontiac Montana SV6

Joined
Jul 11, 2019
Messages
3
Likes
0
Points
1
#1
Make
Pontiac
Model
Montana
Year
2005
Miles
180k~ish
Engine
3.5 V6
All of these things kind of came on over a couple of days. these are the order of things I have done and what transpired afterwards.
The ABS, Traction Control and says it has a charging system failure and am notified in the display while driving.
There were no codes.

- I assumed that the alternator was going bad and possible causing some strange voltages to go cause other issues. I took out the alternator to have a local motor shop inspect it. They replaced the brushes and said that other than them it was in excellent shape.
I put it back in and....

The gear selection does not display.
The starter does not engage.
ODB cannot connect.

- I checked the fuses for the PCM and the ABS and they are both good BUT I checked it while the key was turned on and I get no power out of the fuse socket.

Any help would be greatly appreciated.
 
Last edited:

grcauto

Hero Member
Joined
May 29, 2014
Messages
518
Likes
32
Points
28
#2
Go back over your install of the alternator.
 
Joined
Jul 11, 2019
Messages
3
Likes
0
Points
1
#3
It is fine. All connections secure.

now the gas gauge does not work. There are a lot of fuse sockets that I would think should have power that do not.

ABS
PCM IGN
ELEC IGN
FUEL INJ
 
Joined
Jul 11, 2019
Messages
3
Likes
0
Points
1
#5
They are both good. I use the engine as a ground for a lot of the testing and have used the body as well.
 

nickb2

Wrench. Diagnostic Tech.
Joined
Nov 22, 2008
Messages
9,523
Likes
172
Points
63
Location
St-Hyacinthe, Quebec, Canada
#8
This sounds like a BUS/CAN line problem. Client cant get codes, no comm.

We should look there first and foremost to find solution.

A class 2 serial data problem will cause just these sorts of issues.

First find out why dlc connector is not comm with PCM/VCU/VCM. Btw, not same pdf, just did not want to rename, just overwrote.
 

Attachments

Last edited:

nickb2

Wrench. Diagnostic Tech.
Joined
Nov 22, 2008
Messages
9,523
Likes
172
Points
63
Location
St-Hyacinthe, Quebec, Canada
#9
I don't t care if starter is new, alt is new, ignition switch is new, etc. if you are not getting com at dlc connector, this is your first step.

By tracing that circuit, you will most likely find the rest.

So a few questions, what scanner are you using, or is it just a code reader from walmart? Even a walmart one will give pcm codes.

Do you know how to test a DLC connector? If your code reader/scanner powers up, but cant connect to a control unit, it is a serial/uart/bus line problem. Starting/charging/everything you are experiencing, such as no gear selection display etc, all indicate a bus line cut. Focus there. Once that is out of the way, we will have to go Mc Guyver or as my favorite, sherlock.

By now you should be looking at instrument panel fuse/relay panel, the onstar fuse (fuse # 6- 10amp) controls power to VCU and DLC. VCU means vehicle control unit.

If that is ok, post back, I will provide further assistance.

But first, I must know you have eliminated all fuses first. I mean ALL.
 
Last edited:

nickb2

Wrench. Diagnostic Tech.
Joined
Nov 22, 2008
Messages
9,523
Likes
172
Points
63
Location
St-Hyacinthe, Quebec, Canada
#10
Also, these under-hood relay/fuse boxes are insanely renowned for corrosion of the printed circuit board sending ppl on wild goose chases, so looking there and visually inspecting the underneath of that is a good way to start also. Turn it over, you can also separate. Look closely.

You just may find your issue there with a visual inspection. ;):bat:
 

nickb2

Wrench. Diagnostic Tech.
Joined
Nov 22, 2008
Messages
9,523
Likes
172
Points
63
Location
St-Hyacinthe, Quebec, Canada
#12
Starter will not engage cuz it does not know what gear it is in because cluster is in data line corruption, thus can't complete ciruit. , OBD won't connect because the communication line is broken.

Are we seeing a common theme here? ABS and trac are reporting you have a charging circuit issue, but you can't connect to pcm to get codes. Charging and starting are strictly reserved via pcm on serial data line. Read the pdfs I uploaded. They all say the same.
 

nickb2

Wrench. Diagnostic Tech.
Joined
Nov 22, 2008
Messages
9,523
Likes
172
Points
63
Location
St-Hyacinthe, Quebec, Canada
#13
Ok, I think I just beat the dog enough to give chase to issue. I will now commence BBQ and beer drinking.

I leave you all on this nice weekend, with a party tune. BTW, my sister got out of hospital Thursday. :D

 
Joined
Aug 28, 2007
Messages
4,733
Likes
24
Points
38
#14
No start confuses me, either doesn't crank, or cranks, but the engine doesn't fire.

Wonder how much did they charge you to replace the brushes in that CS series alternator, have to take it all apart and cut off the stator leads welded on, really have to do a good job to solder them back on. Front bearing was peened it, aluminum hardens and get brittle, can never peen them in again. I drill three screws using #10 flat head screws with Locktite with the edges overlapping the ball bearing.